I'd be very happy for the diagnostic text to use more specialized terminology when it can -- I think that makes the user experience quite a bit better.
Not sure its worth having two flags though. On Mon, Jul 2, 2012 at 5:38 PM, Jordan Rose <[email protected]> wrote: > I will again say that Objective-C has "instance variables", not "fields" > or "member variables". But even then I think "field" is better than > "memvar" or "member variable", even though "ivar" is fairly well-known in > Objective-C (and is present in some of our warnings). > > > On Jul 2, 2012, at 5:00 PM, Chandler Carruth wrote: > > > LGTM. If someone wants to re-paint the bikeshed, they should repaint all > of them. This seems a strict improvement as the number of colors goes down > by one. > > > > > > On Mon, Jul 2, 2012 at 4:56 PM, Nico Weber <[email protected]> wrote: > > Hi, > > > > the attached patch renames -Wself-assign-memvar to > > -Wself-assign-field. matthewbg requested this, to match > > -Wunused-private-field. > > > > (If people don't like this, andersca points out that we should rename > > the flag to -Wself-assign-member-variable instead. Let me know which > > version you prefer.) > > > > Nico > > > > _______________________________________________ > > cfe-commits mailing list > > [email protected] > > http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits > > > > > > _______________________________________________ > > cfe-commits mailing list > > [email protected] > > http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits > >
_______________________________________________ cfe-commits mailing list [email protected] http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits
