NoQ added inline comments.

================
Comment at: include/clang/StaticAnalyzer/Core/PathSensitive/Regions.def:31
@@ +30,3 @@
+// is both instantiated and derived from.
+// Additionally, its kind is not its name with "Kind" suffix,
+// unlike all other regions.
----------------
zaks.anna wrote:
> I'd rather rename the "Kind" suffix. Is that possible?
> 
> Having REGION and NORMAL_REGION is strange.
In fact, `MemSpaceRegion` is quite special, because it is the only thing in the 
hierarchy that can be both derived from (normally such values are marked as 
"abstract") and instantiated (for which it has a kind defined). Instances of 
MemSpaceRegion are used, at least, for holding some code regions. Probably 
create a new memspace for such regions and remove the kind value?

Ok, i'd go ahead and prepare a separate review for unifying the naming 
convention :)


http://reviews.llvm.org/D15448



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to