NoQ accepted this revision.
NoQ added a comment.
This revision is now accepted and ready to land.

Ok, so the point is to fix the current checker name problem, right? I guess 
let's land it then :)

Code looks great. I'm thinking aloud in inline comments a little bit, but don't 
mind me.

@rnkovacs, do you have any immediate opinions on how the header structure 
changes here?



================
Comment at: lib/StaticAnalyzer/Checkers/InnerPointer/InnerPointerChecker.h:23-25
+  CallDescription AppendFn, AssignFn, ClearFn, CStrFn, DataFn, EraseFn,
+      InsertFn, PopBackFn, PushBackFn, ReplaceFn, ReserveFn, ResizeFn,
+      ShrinkToFitFn, SwapFn;
----------------
We should eventually initialize these in place.


================
Comment at: lib/StaticAnalyzer/Frontend/CheckerRegistry.cpp:160
+         firstRelatedChecker != lastRelatedChecker; ++firstRelatedChecker) {
+      if (opt.second) {
+        // Enable the checker.
----------------
Because we already forget by now what the second part of this pair is, i 
believe that decomposing a `std::pair` into two variables as early as possible 
is a good idea.


Repository:
  rC Clang

https://reviews.llvm.org/D54438



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to