stephanemoore marked an inline comment as done. stephanemoore added inline comments.
================ Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:1479 +/// \endcode +AST_MATCHER_P(ObjCInterfaceDecl, isSubclassOfInterface, + internal::Matcher<ObjCInterfaceDecl>, ---------------- I am still uncertain about the naming. `isSubclassOf` seemed too generic as that could apply to C++ classes. `objcIsSubclassOf` seemed unconventional as a matcher name. `isSubclassOfObjCInterface` and `isSubclassOfObjCClass` seemed awkwardly lengthy. Creating a new namespace `clang::ast_matchers::objc` seemed unprecedented. I am happy to change the name if you think another name would be more appropriate. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60543/new/ https://reviews.llvm.org/D60543 _______________________________________________ cfe-commits mailing list email@example.com https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits