rsmith accepted this revision.
rsmith added inline comments.
This revision is now accepted and ready to land.


================
Comment at: lib/Basic/Module.cpp:324
 
+Module *Module::findOrCreateSubmodule(StringRef Name) {
+  llvm::StringMap<unsigned>::const_iterator Pos = SubModuleIndex.find(Name);
----------------
Maybe `findOrInferSubmodule`; the current name suggests that this would always 
create a submodule if one doesn't exist (like `ModuleMap::findOrCreateModule` 
does).


================
Comment at: lib/Lex/Pragma.cpp:1587-1588
     // be loaded or implicitly loadable.
     // FIXME: We could create the submodule here. We'd need to know whether
     // it's supposed to be explicit, but not much else.
+    auto &HSI = PP.getHeaderSearchInfo();
----------------
Remove fixed FIXME please :)


================
Comment at: test/Modules/preprocess-umbrella.cpp:1-2
+// FIXME: The standalone module still seems to cause clang to want to test for
+// the existence of a 'foo' directory:
+// RUN: mkdir %t
----------------
FWIW, I think that probably happens when parsing the `umbrella "foo"` directive.


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D61656/new/

https://reviews.llvm.org/D61656



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
  • [PATCH] D61656: -... David Blaikie via Phabricator via cfe-commits
    • [PATCH] D616... David Blaikie via Phabricator via cfe-commits
    • [PATCH] D616... Richard Smith - zygoloid via Phabricator via cfe-commits
    • [PATCH] D616... David Blaikie via Phabricator via cfe-commits
    • [PATCH] D616... David Blaikie via Phabricator via cfe-commits

Reply via email to