yaxunl marked an inline comment as done.
yaxunl added inline comments.

================
Comment at: clang/test/CodeGenCUDA/linker-options.cu:1-5
+// RUN: %clang_cc1 -emit-llvm -o - -fcuda-is-device -fms-extensions -x hip %s \
+// RUN:   -fno-autolink -triple amdgcn-amd-amdhsa \
+// RUN:   | FileCheck -check-prefix=DEV %s
+// RUN: %clang_cc1 -emit-llvm -o - -fms-extensions -x hip %s -triple \
+// RUN:    x86_64-pc-windows-msvc | FileCheck -check-prefix=HOST %s
----------------
tra wrote:
> This appears to be specific to HIP on windows. If that's intended, then the 
> file should be renamed to something like `hip-ms-linker-options.cu`. If the 
> changes in functionality apply on other platforms, or with CUDA, the file 
> name can remain as is, but it would be great to add some test runs for the 
> other uses cases.
the change in functionality applies to HIP and CUDA on windows only. will 
rename it to ms-linker-options.cu and add test for CUDA when committing.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57829/new/

https://reviews.llvm.org/D57829



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to