njames93 added inline comments.

================
Comment at: 
clang-tools-extra/clang-tidy/readability/RedundantStringInitCheck.cpp:143
+          Result.Nodes.getNodeAs<CXXCtorInitializer>("ctorInit")) {
+    if (auto *Member = CtorInit->getMember()) {
+      if (!Member->hasInClassInitializer() ||
----------------
Eugene.Zelenko wrote:
> Could it be const auto *?
This shouldn't be auto anyway. Also the reason its ``auto *`` and not ``const 
auto *`` is because that's the qualified type getMember returns. But in this 
example as I'm not modifying I could add a const qualifier


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72448/new/

https://reviews.llvm.org/D72448



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to