baloghadamsoftware marked 3 inline comments as done.
baloghadamsoftware added inline comments.


================
Comment at: clang/lib/StaticAnalyzer/Checkers/IteratorModeling.cpp:359
     State = State->BindExpr(CE, LCtx, RetVal);
   }
 
----------------
Maybe I should move these lines into a separate function in the library to 
avoid repetition.


================
Comment at: clang/lib/StaticAnalyzer/Checkers/IteratorModeling.cpp:377
+      C.addTransition(StateNonEqual);
   }
+
----------------
This is way longer than the previously used `processComparison()` but I am 
reluctant to pass `CheckerContext` to a non-member function. (And especially 
add transitions there. Even worse, to a function in a common library.)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76590/new/

https://reviews.llvm.org/D76590



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to