sammccall marked 11 inline comments as done.
sammccall added inline comments.
Herald added a subscriber: wangpc.


================
Comment at: clang/include/clang/Analysis/FlowSensitive/Formula.h:69
+
+  Atom atom() const {
+    assert(kind() == AtomRef);
----------------
gribozavr2 wrote:
> Should it be called getAsAtom() or castAsAtom() ? For uniformity with other 
> names in Clang and LLVM.
> 
> 
This isn't quite a cast - the distinction between a variable's identity and a 
reference to it is real.
renamed to `getAtom()`


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D153366/new/

https://reviews.llvm.org/D153366

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to