yaxunl marked an inline comment as done.
yaxunl added inline comments.

================
Comment at: clang/include/clang/Driver/Options.td:1092
   ShouldParseIf<hip.KeyPath>;
+defm hip_uniform_block : BoolFOption<"hip-uniform-block",
+  LangOpts<"HIPUniformBlock">, DefaultTrue,
----------------
arsenm wrote:
> Can we avoid adding yet another language flag for something that's reusable 
> for everything? Is there an --offload-<something> ?
Currently, the naming convention for shared CUDA/HIP language options is 
`-fgpu-*` or `--gpu-* . The shared CUDA/HIP/OpenMP driver options are named 
`--offload-*`.

This option is named `-fhip-uniform-block` because AFAIK CUDA does not support 
non-uniform block size.

If we want to make it a generic option, it should be named as 
`-fgpu-uniform-block` by the current naming convention. Unless we want to 
change the naming convention for generic offloading language options.

@tra What do you think? Thanks.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D155213/new/

https://reviews.llvm.org/D155213

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to