donat.nagy accepted this revision.
donat.nagy added a comment.
This revision is now accepted and ready to land.

This seems to be a straightforward improvement over the current situation; LGTM 
if you test(ed) it on some real-life code (to ensure that it doesn't introduce 
a corner case that crashes).



================
Comment at: clang/lib/StaticAnalyzer/Checkers/ArrayBoundCheckerV2.cpp:46
 
+  void impl(SVal Loc, bool isLoad, const Stmt *S, CheckerContext &C) const;
+
----------------
I'd call this function `performCheck` or something similar, but "`impl`" is 
also fine especially if it's a traditional name (that I haven't encountered yet 
in clang SA code).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D159106/new/

https://reviews.llvm.org/D159106

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to