dcoughlin added inline comments.

================
Comment at: lib/StaticAnalyzer/Checkers/RetainCountChecker.cpp:2000
+        if (Sym->getType().isNull()) {
+          os << " returns an Objective-C object with a ";
+        } else {
----------------
I think we should use this diagnostic text when type is not an 
ObjCObjectPointerType also. Where this matters, I think, is for id.

It seems weird to say "returns an instance of id"; I think it would be better 
in that case to say "returns an Objective-C object".


https://reviews.llvm.org/D27740



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to