aaron.ballman added a comment.

I don't see anything that looks amiss, but you should wait for @rsmith to 
approve.



================
Comment at: lib/Sema/SemaChecking.cpp:2520
+
+// TODO: Call can technically be a const CallExpr, but const_casting feels 
ugly,
+// and I really don't want to duplicate unwrapCallExpr's logic. No caller 
really
----------------
Thank you for this comment; I was about to ask about that very topic. :-D


================
Comment at: lib/Sema/SemaChecking.cpp:11933
 }
-
----------------
Unintended change?


================
Comment at: lib/Sema/SemaOverload.cpp:6235
+  SmallVector<const DiagnoseIfAttr *, 8> Attrs;
+  for (const auto *DIA : FD->specific_attrs<DiagnoseIfAttr>())
+    if (ArgDependent == DIA->getArgDependent())
----------------
Braces might make this a bit easier to read due to the multiline if.


https://reviews.llvm.org/D28889



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to