alexfh requested changes to this revision.
alexfh added inline comments.
This revision now requires changes to proceed.


================
Comment at: clang-tidy/readability/MisleadingIndentationCheck.cpp:72
+        SM.getExpansionColumnNumber(NextLoc))
+      diag(NextLoc, "misleading indentation: statement is indented too 
deeply");
+  }
----------------
Will it be useful to add a note pointing to the control statement and saying 
"did you mean this line to be inside this if/while/for/..."?


================
Comment at: clang-tidy/readability/MisleadingIndentationCheck.cpp:79
+  Finder->addMatcher(
+      compoundStmt(anyOf(has(ifStmt()), has(forStmt()), has(whileStmt())))
+          .bind("compound"),
----------------
`has(anyOf(ifStmt(), forStmt(), whileStmt()))` would read better.


https://reviews.llvm.org/D19586



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to