aprantl added inline comments.

================
Comment at: lib/CodeGen/CGDebugInfo.cpp:4246
+      if (it == TypeCache.end())
+        continue;
+
----------------
What does it mean that a type is not being found in the cache here?


================
Comment at: lib/CodeGen/CGDebugInfo.h:102
+  struct ObjCMethodCacheEntry {
+    const ObjCMethodDecl *MD;
+    llvm::DISubprogram *DIMethodDecl;
----------------
The field naming scheme in this struct is not very consistent :-)


================
Comment at: test/CodeGenObjC/debug-info-category.m:45
+// CHECK: = distinct !DISubprogram(name: "-[Foo integer:]"{{.*}}isDefinition: 
true
+// CHECK: = distinct !DISubprogram(name: "-[Foo(Bar) add:]"{{.*}}isDefinition: 
true
----------------
perhaps also add a class method and a category to the test case?


https://reviews.llvm.org/D48241



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to