hokein added inline comments.

================
Comment at: 
clang-tidy/readability/InconsistentDeclarationParameterNameCheck.cpp:96
+bool nameMatch(StringRef L, StringRef R) {
+  return L.contains_lower(R) || R.contains_lower(L);
+}
----------------
I have a concern that this is too general -- it will cover the middle case like 
`inBFix` in you test, which seems not happen often in the real world.

Two important cases are prefix and suffix, maybe just restrict to these two 
cases?  


Repository:
  rCTE Clang Tools Extra

https://reviews.llvm.org/D49285



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to