Changeset: b052b2c5ea63 for MonetDB
URL: http://dev.monetdb.org/hg/MonetDB?cmd=changeset;node=b052b2c5ea63
Modified Files:
        buildtools/conf/MonetDB.m4
Branch: default
Log Message:

merged configure fix from Jun2010


diffs (23 lines):

diff -r 2b959e43c8f2 -r b052b2c5ea63 buildtools/conf/MonetDB.m4
--- a/buildtools/conf/MonetDB.m4        Sat Jul 24 11:05:12 2010 +0200
+++ b/buildtools/conf/MonetDB.m4        Sun Jul 25 08:13:00 2010 +0200
@@ -2353,12 +2353,16 @@
 
 AC_CHECK_HEADERS([sys/socket.h winsock.h])
 
+have_getaddrinfo=no
 save_LIBS="$LIBS"
 LIBS="$LIBS $SOCKET_LIBS"
-AC_CHECK_FUNC(getaddrinfo, [], [
-  AC_CHECK_LIB(socket, getaddrinfo, [ SOCKET_LIBS="$SOCKET_LIBS -lsocket" ],
-    AC_CHECK_LIB(nsl,  getaddrinfo, [ SOCKET_LIBS="$SOCKET_LIBS -lnsl"    ] 
))])
+AC_CHECK_FUNC(getaddrinfo, [ have_getaddrinfo=yes ], [
+  AC_CHECK_LIB(socket, getaddrinfo, [ SOCKET_LIBS="$SOCKET_LIBS -lsocket"; 
have_getaddrinfo=yes ],
+    AC_CHECK_LIB(nsl,  getaddrinfo, [ SOCKET_LIBS="$SOCKET_LIBS -lnsl"   ; 
have_getaddrinfo=yes ] ))])
 LIBS="$save_LIBS"
+if test "x$have_getaddringo" = xyes; then
+       AC_DEFINE([HAVE_GETADDRINFO], 1, [Define to 1 if you have the 
`getaddrinfo' function.])
+fi
 
 dnl incase of windows we need to use try_link because windows uses the
 dnl pascal style of function calls and naming scheme. Therefore the 
_______________________________________________
Checkin-list mailing list
[email protected]
http://mail.monetdb.org/mailman/listinfo/checkin-list

Reply via email to