Changeset: fcab096fa0e3 for MonetDB
URL: http://dev.monetdb.org/hg/MonetDB?cmd=changeset;node=fcab096fa0e3
Modified Files:
        monetdb5/extras/rdf/rdf.h
        monetdb5/extras/rdf/rdfschema.c
Branch: rdf
Log Message:

Use name instead of candidate for S1


diffs (36 lines):

diff --git a/monetdb5/extras/rdf/rdf.h b/monetdb5/extras/rdf/rdf.h
--- a/monetdb5/extras/rdf/rdf.h
+++ b/monetdb5/extras/rdf/rdf.h
@@ -99,7 +99,8 @@ RDFpartialjoin (bat *res, bat *lmap, bat
 #define INFO_WHERE_NAME_FROM 1
 #define TOP_GENERAL_NAME 2     //Level of hierrachy in which a name is 
considered to be a general name
                                //For example, PERSON, THING is at level 1      
-#define        USE_ALTERNATIVE_NAME 0  //Use different but may be better name 
for a general name
+#define        USE_ALTERNATIVE_NAME 1  //Use different but may be better name 
for a general name
+#define USE_NAME_INSTEADOF_CANDIDATE_IN_S1 1   //Use name instead of candidate 
for merging CS's in S1
 
 // Final data structure that stores the labels for tables and attributes
 typedef struct CSlabel {
diff --git a/monetdb5/extras/rdf/rdfschema.c b/monetdb5/extras/rdf/rdfschema.c
--- a/monetdb5/extras/rdf/rdfschema.c
+++ b/monetdb5/extras/rdf/rdfschema.c
@@ -3300,6 +3300,11 @@ LabelStat* initLabelStat(void){
 #if USE_ALTERNATIVE_NAME 
 static
 oid getMostSuitableName(CSlabel *labels, int freqIdx, int candIdx){
+       #if USE_NAME_INSTEADOF_CANDIDATE_IN_S1
+               (void) candIdx;
+
+               return labels[freqIdx].name; 
+       #else
        oid candidate; 
        int i; 
        candidate = labels[freqIdx].candidates[candIdx];
@@ -3322,6 +3327,7 @@ oid getMostSuitableName(CSlabel *labels,
                
        //No choice                     
        return candidate; 
+       #endif
 
 }
 #endif
_______________________________________________
checkin-list mailing list
[email protected]
https://www.monetdb.org/mailman/listinfo/checkin-list

Reply via email to