Changeset: 67a78d44eb01 for MonetDB
URL: https://dev.monetdb.org/hg/MonetDB/rev/67a78d44eb01
Modified Files:
gdk/gdk.h
monetdb5/optimizer/opt_pushselect.c
Branch: Jul2021
Log Message:
Use a define instead of a "magic number".
diffs (41 lines):
diff --git a/gdk/gdk.h b/gdk/gdk.h
--- a/gdk/gdk.h
+++ b/gdk/gdk.h
@@ -375,6 +375,7 @@ typedef enum { GDK_FAIL, GDK_SUCCEED } g
#define PERFMASK (1<<12)
#define DELTAMASK (1<<13)
#define LOADMASK (1<<14)
+#define PUSHCANDMASK (1<<15) /* used in opt_pushselect.c */
#define ACCELMASK (1<<20)
#define ALGOMASK (1<<21)
diff --git a/monetdb5/optimizer/opt_pushselect.c
b/monetdb5/optimizer/opt_pushselect.c
--- a/monetdb5/optimizer/opt_pushselect.c
+++ b/monetdb5/optimizer/opt_pushselect.c
@@ -246,7 +246,7 @@ OPTpushselectImplementation(Client cntxt
}
}
/* left hand side */
- if ( (GDKdebug & (1<<15)) &&
+ if ( (GDKdebug & PUSHCANDMASK) &&
isMatJoinOp(p) && p->retc == 2) {
int i1 = getArg(p, 2), tid = 0;
InstrPtr q = old[vars[i1]];
@@ -276,7 +276,7 @@ OPTpushselectImplementation(Client cntxt
}
}
/* right hand side */
- if ( (GDKdebug & (1<<15)) &&
+ if ( (GDKdebug & PUSHCANDMASK) &&
isMatJoinOp(p) && p->retc == 2) {
int i1 = getArg(p, 3), tid = 0;
InstrPtr q = old[vars[i1]];
@@ -419,7 +419,7 @@ OPTpushselectImplementation(Client cntxt
p->blk = NULL;
actions++;
}
- } else if ( (GDKdebug & (1<<15)) && isMatJoinOp(p) &&
p->retc == 2) {
+ } else if ( (GDKdebug & PUSHCANDMASK) && isMatJoinOp(p)
&& p->retc == 2) {
int ltid = 0, rtid = 0, done = 0;
int range = 0;
_______________________________________________
checkin-list mailing list
[email protected]
https://www.monetdb.org/mailman/listinfo/checkin-list