Changeset: 1f28cf7e1729 for MonetDB
URL: https://dev.monetdb.org/hg/MonetDB/rev/1f28cf7e1729
Modified Files:
        sql/backends/monet5/rel_bin.c
Branch: directappend
Log Message:

Rename can_use_appendfrom to can_use_directappend

Als directappend is now the name of the branch.


diffs (21 lines):

diff --git a/sql/backends/monet5/rel_bin.c b/sql/backends/monet5/rel_bin.c
--- a/sql/backends/monet5/rel_bin.c
+++ b/sql/backends/monet5/rel_bin.c
@@ -4260,7 +4260,7 @@ dump_code(int starting_point)
 // code. The idea is that we'll gradually add support for more cases and 
shorten
 // this list until it disappears.
 static sql_exp*
-can_use_appendfrom(sql_rel *rel)
+can_use_directappend(sql_rel *rel)
 {
        if (rel->flag & UPD_NO_CONSTRAINT) {
                // "no constraint" mode.. don't know what it is but it sounds 
scary
@@ -4449,7 +4449,7 @@ rel2bin_insert(backend *be, sql_rel *rel
 
        // If can_use_appendfrom doesn't return NULL, short circuit to
        // the temporary dedicated code generator
-       sql_exp *copyfrom = can_use_appendfrom(rel);
+       sql_exp *copyfrom = can_use_directappend(rel);
        if (copyfrom != NULL) {
                // later on we'll do this properly, passing an extra parameter,
                // for now we adjust an existing parameter.
_______________________________________________
checkin-list mailing list
[email protected]
https://www.monetdb.org/mailman/listinfo/checkin-list

Reply via email to