Hallo Alexander,

Prüfe mal auf deiner Site, wie die Auslastung der Check-Helper ist. Ab 
einer gewissen Anzahl an Services und Hosts reicht der Default nicht mehr 
aus und man muss etwas nachjustieren. Das kannst du in den global settings 
im Bereich Monitoring Core tun. Anschließend muss der Core neu gestartet 
werden, damit zusätzliche Prozesse gestartet werden, die die Checks 
ausführen.

Generell Hilft bei solchen Problemen immer ein Blick in das SnapIn Micro 
Core Statistics oder Server Performance.

Wir nutzen bei 2.200 Hosts und 30.000 Services 200 concurrent Check_MK 
Checks als Einstellung.


Mit freundlichen Grüßen

i.A. Tobias Schönau
SAP Basis
EDV

EDEKA Handelsgesellschaft Hessenring mbH
Industriegebiet Pfieffewiesen
34212 Melsungen

Tel.:   05661/72-486

E-Mail: tobias.schoe...@edeka.de

_________________________________________________________________

EDEKA Handelsgesellschaft Hessenring mbH, Melsungen
Geschäftsführer: Hans-Richard Schneeweiß (Sprecher), Hans-Jürgen Steffen
Aufsichtsratsvorsitzender: Tobias Schnabel
Eingetragen im Handelsregister des Amtsgerichts Fritzlar, HRB 11100
USt-IdentNr.: DE 1130 55864



Von:    Alexander Leutz <alexander.le...@gmail.com>
An:     checkmk-de@lists.mathias-kettner.de
Datum:  14.02.2018 09:46
Betreff:        [Check_mk (deutsch)] check_mk -> ubuntu -> fs buffer
Gesendet von:   "checkmk-de" <checkmk-de-boun...@lists.mathias-kettner.de>



Hallo zusammen,

Wir haben check_mk 1.4.0p19 auf ubuntu 16.04.3 LTS auf einem 
physikalischen Server laufen.
Aktuell haben wir über 6000 services erreicht und planen mehr.

Das System hat den gesamten RAM als FS Buffer in Verwendung – was ja 
eigentlich nicht verkehrt ist. Gleichzeitig sehe ich jedoch in der GUI 
massenhaft Dienste, die den Status „STALE“ haben – also nicht wirklich 
innerhalb des definierten Check-Intervalls abgebildet werden. Zwar 
„fangen“ sich diese Dienste überwiegend nach einigen Minuten wieder, 
jedoch ist der Zeitraum leider nicht genau definiert. So hatte ich heute 
morgen Dienste, die mehrere Tage „STALE“ waren und erst nach einem 
manuellen Re-Check wieder den Staus „normal“ angenommen haben.

Mir scheint, dass hier tatsächlich irgendwas nicht rund läuft.

Hat jemand eine Idee dazu? Ich bin mir nicht sicher, ob das am Ubuntu oder 
am check_mk liegt...?

top - 10:49:11 up 19 days, 20:10,  1 user,  load average: 1.65, 1.70, 1.97
Tasks: 481 total,   2 running, 479 sleeping,   0 stopped,   0 zombie
%Cpu(s):  7.8 us,  2.1 sy,  0.0 ni, 89.9 id,  0.0 wa,  0.0 hi,  0.3 si,  
0.0 st
KiB Mem : 65597292 total,   638580 free,  1279836 used, 63678876 
buff/cache
KiB Swap: 66994172 total, 66854488 free,   139684 used. 63427816 avail Mem

Danke & Gruß
Alexander_______________________________________________
checkmk-de mailing list
checkmk-de@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-de

_______________________________________________
checkmk-de mailing list
checkmk-de@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-de

Antwort per Email an