Hi all,

I'm getting errors trying to compile the latest source code into an RPM on
CentOS 6.8. Below is the error that I'm getting:

creating build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/utility.py -> build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/pyclass.py -> build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/__init__.py -> build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/wsdl2python.py ->
build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/containers.py ->
build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/wsdl2dispatch.py ->
build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/generate/commands.py -> build/lib/pysphere/ZSI/generate
copying pysphere/ZSI/LBNLCopyright -> build/lib/pysphere/ZSI
running install
Traceback (most recent call last):
  File "setup.py", line 65, in <module>
    long_description=long_desc
  File
"/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python/tmp.python27/lib/python2.7/distutils/core.py",
line 151, in setup
    dist.run_commands()
  File
"/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python/tmp.python27/lib/python2.7/distutils/dist.py",
line 953, in run_commands
    self.run_command(cmd)
  File
"/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python/tmp.python27/lib/python2.7/distutils/dist.py",
line 972, in run_command
    cmd_obj.run()
  File
"/omd/versions/1.30/lib/python/setuptools-0.6c11-py2.6.egg/setuptools/command/install.py",
line 76, in run
  File
"/omd/versions/1.30/lib/python/setuptools-0.6c11-py2.6.egg/setuptools/command/install.py",
line 85, in do_egg_install
  File
"/omd/versions/1.30/lib/python/setuptools-0.6c11-py2.6.egg/setuptools/dist.py",
line 395, in get_command_class
  File
"/omd/versions/1.30/lib/python/setuptools-0.6c11-py2.6.egg/pkg_resources.py",
line 1954, in load
  File
"/omd/versions/1.30/lib/python/setuptools-0.6c11-py2.6.egg/setuptools/command/easy_install.py",
line 12, in <module>
  File
"/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python/tmp.python27/lib/python2.7/tempfile.py",
line 35, in <module>
    from random import Random as _Random
  File
"/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python/tmp.python27/lib/python2.7/random.py",
line 49, in <module>
    import hashlib as _hashlib
  File "/omd/versions/1.30/lib/python/hashlib.py", line 115, in <module>
    f()
TypeError: 'frozenset' object is not callable
make[2]: *** [build] Error 1
make[2]: Leaving directory
`/root/repos/omd/rpm.topdir/BUILD/omd-1.30/packages/python-modules'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/root/repos/omd/rpm.topdir/BUILD/omd-1.30'
error: Bad exit status from /var/tmp/rpm-tmp.s9WDSY (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.s9WDSY (%build)
make: *** [rpm] Error 1
[root@omdistro130 omd]#

This was on a brand new clone of the repo running a compile on a CentOS 6.8
box. I've ran the compiling before without issues.

Thanks for the help in advance.
Jesus
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to