Hi,

  We have been trying to set up automatic agent updates, just as a test for a 
few (Ubuntu Linux) servers.

  Registering the update agents plugins to the server seemed to work just fine. 
However, we are seeing this in our view:

WARN - error: The agent updater is not registered at the deployment serverWARN, 
no successful connect to server yetWARN

  The interesting part is, that on the server, if I run the update agent with 
-u ("run like a plugin") I get this:

# cmk-update-agent -u
<<<check_mk>>>
AgentUpdate: last_check 1474434035.99 last_update 1474356408.81 aghash None 
error None

  But, if I run 

# check_mk_agent test | tail -2
<<<check_mk>>>
AgentUpdate: last_check None last_update None aghash None error The agent 
updater is not registered at the deployment server

  (Also, on a related note, to get the agent installed we needed to install 
curl and python-requests on the server - the .deb-package did not apparently 
include those as dependencies).

  Any ideas on what could cause this?

  We are running the agent as root...

- Antti
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to