I found a solution by adding the password as a macro in resource.cfg and 
escaping the $ in a user defined macro...


Then reference the macro in the specific check_jmx4perl check defined within 

Problem solved


From: checkmk-en-boun...@lists.mathias-kettner.de 
[mailto:checkmk-en-boun...@lists.mathias-kettner.de] On Behalf Of 
Sent: Thursday, October 13, 2016 3:25 PM
To: checkmk-en@lists.mathias-kettner.de
Subject: [Check_mk (english)] check_jmx4perl Special Characters and macros

Sorry if this is documented but I wasn't able to find it...

I have a standard check setup via WATO that has a special character in the 
password.  It is
check_jmx4perl --user username --password pa$word --config 
$USER4$/etc/jmx4perl/jmx4perl.cfg --server $HOSTNAME$ --check memory_heap

Which results in an obvious issue of the character being understood as defining 
a Macro:
UNKNOWN - No configuration file $/etc/jmx4perl/jmx4perl.cfg found

I tried a couple of things:
1:      escape the character using pa\$word which results in a generated 
configuration with a double escape --password pa\\$word
2:      From the command line it works with single quotes --password 'pa$word' 
but that doesn't seem to help with setting it up in WATO

How do I escape the special character in the password without changing the 


checkmk-en mailing list

Reply via email to