It is not related to your cmk-pusher script.

Can you share the config of check_mk? The regular ini file in which you added 
the mrpe command?
Also: can you follow up on my question to add the log write action as the first 
line in your powershell script? It will (probably) show that the powershell 
script cannot be executed at all. So in that case it is not related to the 
commands in your scripts.

Verstuurd vanaf mijn iPhone

> Op 16 okt. 2016 om 23:21 heeft Pavel Vaysman <goa...@gmail.com> het volgende 
> geschreven:
> 
> i push result  with external python program.
> 
> https://github.com/qmexnetworks/cmk-pusher-agent
> 
> but it's not powershell problem...
> 
> when i run this script manually from powershell it's working, from debug mode 
> in cmd "check_mk_agent debug" its working , but  "check_mk_agent test"  - it 
> failed with error..
> 
> this  mrpe check is working with agent 1.2.6p12...
> 
> 
>> On Oct 16, 2016 15:06, "Wouter" <wblee...@gmail.com> wrote:
>> So how is your agent started in your situation? You push the results, so it 
>> doesn't run as a service?
>> Can you get a regular powershell script to write-out any output? When you 
>> add something like "add-content full-path-to-logfile.log test_txt" in the 
>> first line, is your script running at all?
>> 
>> Verstuurd vanaf mijn iPhone
>> 
>>> Op 15 okt. 2016 om 09:05 heeft Pavel Vaysman <goa...@gmail.com> het 
>>> volgende geschreven:
>>> 
>>> I have about 300 server behind firewalls and nat and it's impossible to 
>>> query check_mk agent and snmp from central check_mk server.
>>>  
>>> So i run check_mk agent locally on server and push it's output to check_mk 
>>> server.
>>> 
>>>> On Sat, Oct 15, 2016 at 12:05 AM, ml...@libero.it <ml...@libero.it> wrote:
>>>> Pavel,
>>>> 
>>>> why are you using a powershell script? in my test environment I added some 
>>>> proliant dl servers running linux + hp agents and it worked out of the 
>>>> box. I did not try windows servers but it should be the same; I just 
>>>> selected agent+snmp
>>>> 
>>>> 
>>>> ----Messaggio originale----
>>>> Da: "Pavel Vaysman" <goa...@gmail.com>
>>>> Data: 14/10/2016 17.27
>>>> A: <checkmk-en@lists.mathias-kettner.de>
>>>> Ogg: [Check_mk (english)] windows check_mk_agent 1.2.8p12 with     
>>>> hpacucli.exe
>>>> 
>>>> 
>>>> Hi guys,
>>>> 
>>>> i try to monitor hp raid with mrpe via check_mk_agent 1.2.8p12 with 
>>>> hpacucli.exe.
>>>> I have powershell script that run hpacucli.exe and parsing it's output.
>>>> With check_mk_agent 1.2.6p16 it's working perfect.
>>>> With new check_mk agent 1.2.8pX it's return "ERROR: Cannot open console"
>>>> When i'm run check_mk agent 1.2.8pX with debug argument - it's working.
>>>> Right now , workaround - write hpacucli.exe output to file via windows 
>>>> task scheduler and parse this txt file.
>>>> 
>>>> Is it bug or may be i did mistake somewhere?
>>>> 
>>>> Source Code
>>>> $array_config_util = "c:\hp\Bin\hpacucli.exe" 
>>>> try {
>>>>  $exec = &  $array_config_util  'ctrl all show config' 
>>>> #write-host !!!!!!!!!!!!!!!!!!!!!
>>>> #Write-Output $exec
>>>> }
>>>> catch {
>>>> Write-Host "Problem checking array status)"
>>>> exit 3
>>>> }
>>>> # filter results for lines that talk about drives (physicaldrive, 
>>>> logicaldrive)
>>>> # and do not end with "OK":
>>>> $not_OK = $exec | Where-Object { $_ -like "*drive*" } | Where-Object { $_ 
>>>> -notlike "*OK*)" } 
>>>> #write-output "<<<>>>"
>>>> #write-output $not_OK  
>>>> if ($not_OK.length -lt 1) {
>>>> Write-Host "Array status appears OK"
>>>> exit 0
>>>> }
>>>> Write-Host "Array status not OK; please check RAID software"
>>>> exit 2
>>>> 
>>>> 
>>> 
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to