HI Mathias,

your error message looks more like wrong settings for the host. "Missing
agent sections" looks like the host is defined as checked with agent and
not with snmp.
How looks the configuration of this host? --> cmk -D <hostname>
What do you find there at "Type of agent"?

br
Andreas

Mathias Zimmermann via checkmk-en <checkmk-en@lists.mathias-kettner.de>
schrieb am Do., 10. Aug. 2017 um 14:50 Uhr:

> Hi Arno
>
> Thanks for your reply.
> Unfortunately, I am sure that the function names are unique.
>
> Regards,
> Mathias
>
> On 10.08.17, 14:20, "Arno Wijnhoven" <ar...@vsnsystemen.nl> wrote:
>
>     -sent again with list in cc so they can intervene if I'm lying-
>
>     Hi Mathias,
>
>     I encountered such behaviour as well when I was on an older version of
> Check_MK.
>     I used an existing check as base for my custom check back then.
>
>     If you didn't rename all functions from your base script properly,
> there's a possibility that some functions exist twice in the precompiled
> file - this won't work well.
>     Same goes for Python includes if you use those.
>     So, the single check will work (both from WATO and command line) but
> the regular check will fail.
>     If this is the case, best have a look at the precompiled <hostname>.py
> file (folder name is 'precompiled', don't know exact location though).
>
>     I solved this for me by renaming the functions. In custom scripts, I
> just put my company name in front to make them 100% unique.
>     Example:
>         "check_function"        : companyname_check_juniper_bgp_state,
>         "inventory_function"    : companyname_inventory_juniper_bgp_state,
>
>     Hope this helps!
>
>     Arno Wijnhoven
>
>     -----Original Message-----
>     From: checkmk-en [mailto:checkmk-en-boun...@lists.mathias-kettner.de]
> On Behalf Of Mathias Zimmermann via checkmk-en
>     Sent: donderdag 10 augustus 2017 11:40
>     To: checkmk-en@lists.mathias-kettner.de
>     Subject: [Check_mk (english)] Missing agent sections: juniper_state
>
>     Hi
>
>     I added a custom SNMP check to the OMD site into
> /opt/omd/sites/<site_name>/local/share/check_mk/checks/juniper_state.
>     After a discovery (with cmk –I) the new check is added to the
> appropriate hosts and with cmk –O I can see the new service check.
>
>     But after this, I get a warning at the Check_MK service stating:
> “Missing agent sections: juniper_state - execution time 22.1 sec”.
>
>     When I run cmk –nv host I can see the correct output of the new
> service.
>     But in the webview the service is in state “PEND” and no data is shown
> and I get the message “This service is stale, no data has been received
> within the last 1.5 check periods”.
>
>     What do I miss here to make my local SNMP check work and display the
> correct information at the web GUI?
>
>     Thank you.
>
>     Regards,
>     Mathias
>
>
>     _______________________________________________
>     checkmk-en mailing list
>     checkmk-en@lists.mathias-kettner.de
>     http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
>
>
> _______________________________________________
> checkmk-en mailing list
> checkmk-en@lists.mathias-kettner.de
> http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to