Hi,

I'm using the 1.4.0p24 CRE version

I have some hosts that I want to check the SSL cert age, so in WATO, I've
configured the active http check as follows

Service check command: check_mk_active-http!'-I' '$_HOSTADDRESS_4$' '-C'
'14,7' '--sni'

If I run that via cli on the monitoring host:

OMD[it]:~$ /opt/omd/versions/1.4.0p24.cre/lib/nagios/plugins/check_http
'-I' 'www.myexample.com' '-C' '14,7' '--sni'
CRITICAL - Cannot make SSL connection.

however, if I change the -I argument to -H, it works:

OMD[it]:~$ /opt/omd/versions/1.4.0p24.cre/lib/nagios/plugins/check_http -H '
www.myexample.com' '-C' '14,7' '--sni'
OK - Certificate 'www.myexample.com' will expire on Mon 07 May 2018
06:47:13 PM GMT +0000.

How can I get that '-H' parameter in the check via WATO? Selecting the
"Check Certificate of different IP / DNS Name " seems to add it, and I've
tried putting $_HOSTADDRESS_4$ in the field below, but no change, even
though the check command looks like:

check_mk_active-http!'-H' '$_HOSTADDRESS_4$' '-C' '14,7' '--sni'

which matches my working command line.

Any ideas?
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to