Hi Arno
I have checked the file and all is OK with the # etc. I also ran the
permissions OK, unfortunatley same error.

I see at the bottom

OSError: [Errno 2] No such file or directory:
'/omd/versions/1.5.0b4.cre/lib/cmc/icmpsender'

Not sure why its looking for v1.5 when I have reverted back to 1.4.24p ?

*Wallis Short*   Senior Network Engineer

<http://metrofibre.co.za/>

Metro Fibre Networx (Pty) Ltd
www.metrofibre.co.za

298 Witch-Hazel Ave, Highveld, Centurion, Gauteng, 0157 South Africa
<https://maps.google.com/?q=298+Witch-Hazel+Ave,+Highveld,+Centurion,+Gauteng,+0157+South+Africa&entry=gmail&source=g>


On 17 May 2018 at 15:14, Arno Wijnhoven <ar...@vsnsystemen.nl> wrote:

> 'chkconfig --add httpd && chkconfig httpd on'
>
>
>
> This is causing an error if /etc/init.d/httpd isn’t there or isn’t valid.
>
> The first lines of httpd have to be something like
>
> #chkconfig: 345 80 20
> #description: httpd script
>
> You also need the # in these lines.
>
> Please make sure the script httpd is executable (chmod +x).
>
>
>
> Arno Wijnhoven
>
> T: 2580
>
>
>
> *From:* Wallis Short [mailto:wall...@metrofibre.co.za]
> *Sent:* donderdag 17 mei 2018 15:11
> *To:* Arno Wijnhoven <ar...@vsnsystemen.nl>
>
> *Cc:* checkmk-en@lists.mathias-kettner.de
> *Subject:* Re: [Check_mk (english)] Nagvis
>
>
>
> My bad - I was doing it from the nms user
>
> I now get this error
>
>
>
> Activating init script for "omd"
> Going to execute 'chkconfig --add omd && chkconfig omd on'
> error reading information on service omd: No such file or directory
> ERROR
> Activating init script for "httpd"
> Going to execute 'chkconfig --add httpd && chkconfig httpd on'
> error reading information on service httpd: No such file or directory
> ERROR
> Traceback (most recent call last):
>   File "/usr/bin/omd", line 4381, in <module>
>     command_function(args, command_options)
>   File "/usr/bin/omd", line 2514, in main_setup
>     os.chown(path, -1, gid)
> OSError: [Errno 2] No such file or directory: '/omd/versions/1.5.0b4.cre/
> lib/cmc/icmpsender'
>
>
> *Wallis Short*   Senior Network Engineer
>
> <http://metrofibre.co.za/>
>
> Metro Fibre Networx (Pty) Ltd
> www.metrofibre.co.za
>
> 298 Witch-Hazel Ave, Highveld, Centurion, Gauteng, 0157 South Africa
> <https://maps.google.com/?q=298+Witch-Hazel+Ave,+Highveld,+Centurion,+Gauteng,+0157+South+Africa&entry=gmail&source=g>
>
>
>
>
>
> On 17 May 2018 at 15:08, Wallis Short <wall...@metrofibre.co.za> wrote:
>
> Thats odd !!
>
> When i do omd setup I get
>
>  "root permissions are needed for this command"
>
> .
>
> I am running as root - I am able to stop and start omd OK but not initiate
> the setup command ?
>
>
> *Wallis Short*   Senior Network Engineer
>
> <http://metrofibre.co.za/>
>
> Metro Fibre Networx (Pty) Ltd
> www.metrofibre.co.za
>
> 298 Witch-Hazel Ave, Highveld, Centurion, Gauteng, 0157 South Africa
> <https://maps.google.com/?q=298+Witch-Hazel+Ave,+Highveld,+Centurion,+Gauteng,+0157+South+Africa&entry=gmail&source=g>
>
>
>
>
>
> On 17 May 2018 at 15:03, Arno Wijnhoven <ar...@vsnsystemen.nl> wrote:
>
> Almost forgot:
> If this doesn’t work, please do an ‘omd setup’ with the httpd file in
> place (actually, this is the reason you need the file in that place, just
> for the omd setup command).
>
> This will restore your apache hooks – hopefully it includes the nagvis
> hooks.
>
>
>
> Arno Wijnhoven
>
> T: 2580
>
>
>
> *From:* checkmk-en [mailto:checkmk-en-boun...@lists.mathias-kettner.de] *On
> Behalf Of *Arno Wijnhoven
> *Sent:* donderdag 17 mei 2018 14:59
> *To:* Wallis Short <wall...@metrofibre.co.za>
> *Cc:* checkmk-en@lists.mathias-kettner.de
>
>
> *Subject:* Re: [Check_mk (english)] Nagvis
>
>
>
> Please try this:
>
> -          Copy /usr/sbin/apachectl to /etc/init.d
>
> -          Rename apachectl to httpd
>
> -          Edit httpd and add the following on top of the file:
>
> #chkconfig: 345 80 20
>
> #description: httpd script
>
>
>
> Reboot (httpd restart is prob enough, but I didn’t test that) and retry.
>
> I’m not sure if this solves your issue as mine was slightly different. I’m
> also not sure if this is the most elegant way.
>
> It does solve my problem though.
>
>
>
> Arno Wijnhoven
>
> T: 2580
>
>
>
> *From:* Wallis Short [mailto:wall...@metrofibre.co.za
> <wall...@metrofibre.co.za>]
> *Sent:* donderdag 17 mei 2018 14:55
> *To:* Arno Wijnhoven <ar...@vsnsystemen.nl>
> *Subject:* Re: [Check_mk (english)] Nagvis
>
>
>
> Hi Arno - many thanks for getting back to me!
>
>
>
> I am running Centos 7 and I dont see the httpd file in the folder. I do
> have another dev server running OK with nagvis and it too doesnt have the
> httpd file in /etc/init.d  :(
>
>  Not sure what else to do :(
>
> Cheers
>
> Wallis
>
>
> *Wallis Short*   Senior Network Engineer
>
> <http://metrofibre.co.za/>
>
> Metro Fibre Networx (Pty) Ltd
> www.metrofibre.co.za
>
> 298 Witch-Hazel Ave, Highveld, Centurion, Gauteng, 0157 South Africa
> <https://maps.google.com/?q=298+Witch-Hazel+Ave,+Highveld,+Centurion,+Gauteng,+0157+South+Africa&entry=gmail&source=g>
>
>
>
>
>
> On 17 May 2018 at 14:33, Arno Wijnhoven <ar...@vsnsystemen.nl> wrote:
>
> I’ve encountered something similar using CentOS 7. OMD status showed that
> everything was running, but using a web browser I always got the message
> ‘Please start the site’.
> Turned out I didn’t have the apache service file in /etc/init.d/ and
> apparently OMD expects that file to be there.
>
>
>
> If you are using CentOS 7, can you check if you’ve got a file named
> ‘httpd’ in /etc/init.d/ ?
>
>
>
> Arno Wijnhoven
>
>
>
> *From:* checkmk-en [mailto:checkmk-en-boun...@lists.mathias-kettner.de] *On
> Behalf Of *Wallis Short
> *Sent:* donderdag 17 mei 2018 14:07
> *To:* checkmk-en@lists.mathias-kettner.de
> *Subject:* [Check_mk (english)] Nagvis
>
>
>
> Hi All
>
>
>
> I updated check_mk from 1.4.0p24 to the 15 beta.
>
>
>
> I then reverted back to 1.4.0.p24 and Nagvis has stopped working. its as
> if Apache wasn't running however when I do a omd status, Apache is showing
> as  running
>
>
>
> Anyone able to shed some light?
>
>
>
>
>
> *Wallis Short*   Senior Network Engineer
>
> <http://metrofibre.co.za/>
>
> Metro Fibre Networx (Pty) Ltd
> www.metrofibre.co.za
>
> 298 Witch-Hazel Ave, Highveld, Centurion, Gauteng, 0157 South Africa
> <https://maps.google.com/?q=298+Witch-Hazel+Ave,+Highveld,+Centurion,+Gauteng,+0157+South+Africa&entry=gmail&source=g>
>
>
>
>
>
>
>
>
>
_______________________________________________
checkmk-en mailing list
checkmk-en@lists.mathias-kettner.de
Manage your subscription or unsubscribe
http://lists.mathias-kettner.de/mailman/listinfo/checkmk-en

Reply via email to