Style question: the Chicken 3 version of base64 consists of two
procedures: base64:encode and base64:decode.  For the modularized
version in Chicken 4, should the prefix simply be stripped ("encode",
"decode"), or should they be more descriptive, such as base64-encode
and base64-decode?

I'm leaning toward the latter, because I don't think a namespace is a
substitute for a properly descriptive name.  Taken too far, the former
might lead to modules with a single procedure called "go", "do" or
"execute".  And a (require-extension base64) that pulls in "encode"
and "decode" is nearly useless -- the module system serving to
exacerbate rather than diminish namespace conflicts.

But, I can understand that some may prefer to deal with the
disambiguation at the module level.  Does anyone have any thoughts?


_______________________________________________
Chicken-users mailing list
Chicken-users@nongnu.org
http://lists.nongnu.org/mailman/listinfo/chicken-users

Reply via email to