On 11/18/10 10:03 AM, Felix wrote: > I've put together a little library of generic "sequence" operations, > and would like to get some feedback, since I'm not sure about the > nomenclature and API. Find it here: > > http://wiki.call-cc.org/eggref/4/sequences > > And in the repo, usual place. It has a test-suite, but surely contains > some bugs, and is a bit of a test for the "fast-generic" extension. > > Comments, suggestions, rants or critique is welcome.
This is more of a question rather than criticism, but... Scheme already has a (more or less) established nomenclature for certain actions. For example, to take the length of something, you use length, string-length, vector-length, etc. There are more of these: -ref, -map, -fold, etc. So, I wonder, why not use the same conventions? Instead, I see names like 'size', 'elt', etc. Wouldn't it be clearer to use names like sequence-length, or, if that is too verbose, seq-length, etc...? -- Hans Nowak _______________________________________________ Chicken-users mailing list [email protected] http://lists.nongnu.org/mailman/listinfo/chicken-users
