Relevant chrony.conf snipet:

# offline sources

refclock SHM 0 refid GPS precision 1e-1
refclock SHM 1 refid NMEA precision 1e-9
refclock SOCK /tmp/chrony.ttyS0.sock refid NMEA
refclock PPS /dev/pps0 poll 0 refid PPS lock NMEA

Sources output:

pi@raspberrypi:~ $ sudo chronyc sources
210 Number of sources = 5
MS Name/IP address         Stratum Poll Reach LastRx Last
sample
===============================================================================
#* GPS                       0   4   377 15-+1007us   [-1476us]+/-100ms 
#? NMEA                      0   4     0      -+0ns   [   +0ns]+/-  0ns 
#? NMEA                      0   4     0      -+0ns   [   +0ns]+/-  0ns
#? PPS                       0   0     0      -+0ns   [   +0ns]+/-  0ns 
^? 2610:20:6f15:15::27       0   8     0      -+0ns   [   +0ns]+/-  0ns
pi@raspberrypi:~ $ 

I don't see anything unusual(?) in the log...

I am not an old hand at this......

Thank you!

Brian



>> 

> On Feb 23, 2017, at 09:09, Bill Unruh <un...@physics.ubc.ca> wrote:
> 
> You tell it to lock to NMEA. Do you actually have an NMEA refclock running?
> Ie you might want to show us what your complete chrony.conf is.
> 
> Also in your sources, what sources are listed? Ie, what is the complete 
> output of chronyc sources command.
> 
> In the logging of the refclock, are there any entries? Do they give you a
> clue?
> 
> 
> 
> William G. Unruh __| Canadian Institute for|____ Tel: +1(604)822-3273
> Physics&Astronomy _|___ Advanced Research _|____ Fax: +1(604)822-5324
> UBC, Vancouver,BC _|_ Program in Cosmology |____ un...@physics.ubc.ca
> Canada V6T 1Z1 ____|____ and Gravity ______|_ www.theory.physics.ubc.ca/
> 
>> On Thu, 23 Feb 2017, Brian Gieryk wrote:
>> 
>> Good morning.
>> 
>> Running chrony 3.1, raspberry Pi 3 model B with the latest Raspbian Jessie.
>> 
>> Have GPS working to set the clock with no issue.
>> 
>> Have good PPS on /dev/pps0
>> 
>> From searching the archives I have :
>> refclock PPS /dev/pps0 poll 0 refid PPS lock NMEA
>> 
>> Appended to the end of /etc/chrony/chrony.conf
>> 
>> Running chronyd produces no errors
>> 
>> PPS shows in chronyc sources
>> 
>> However the #? next to PPS never changes (48 hours so far) and there are no 
>> corrections.
>> 
>> Any thoughts?
>> 
>> Thank you all!
>> 
>> Brian
>> 
>> Sent from my iPhone
>> --
>> To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org
>> with "unsubscribe" in the subject.
>> For help email chrony-users-requ...@chrony.tuxfamily.org
>> with "help" in the subject.
>> Trouble?  Email listmas...@chrony.tuxfamily.org.
> 
> -- 
> To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org with 
> "unsubscribe" in the subject.
> For help email chrony-users-requ...@chrony.tuxfamily.org with "help" in the 
> subject.
> Trouble?  Email listmas...@chrony.tuxfamily.org.
> 

--
To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org
with "unsubscribe" in the subject.
For help email chrony-users-requ...@chrony.tuxfamily.org
with "help" in the subject.
Trouble?  Email listmas...@chrony.tuxfamily.org.

Reply via email to