Unfortunately, no:master:~ chronyd --version
chronyd (chrony) version 1.29
master:~ chronyc --version
chronyc (chrony) version 1.29

Which is the same on slave. I also tried apt-get removing (--purge) and 
re-installing, just for good
measure, but still the same result...

But you could have installed a new chronyc and chronyd, but not then restarted
chronyd, so it is still an old version of chronyd running.



2017-04-27 16:26 GMT+01:00 Miroslav Lichvar <mlich...@redhat.com>:
      On Thu, Apr 27, 2017 at 03:35:19PM +0100, Benjamin Schnieders wrote:
      > On master, "sudo chronyc sources" fails with error 506. I've dug a 
little,

      > tcpdump reports the following activity during a "source" call:
      > tcpdump: verbose output suppressed, use -v or -vv for full protocol 
decode
      > listening on lo, link-type EN10MB (Ethernet), capture size 65535 bytes
      > 15:24:37.790275 IP 127.0.0.1.45817 > 127.0.1.1.323: UDP, length 36
      > 15:24:37.790326 IP 127.0.0.1.323 > 127.0.0.1.45817: UDP, length 32
      > 15:24:37.790337 IP 127.0.0.1.45817 > 127.0.1.1.323: UDP, length 36
      > 15:24:37.790349 IP 127.0.0.1.323 > 127.0.0.1.45817: UDP, length 32
      > 15:24:37.790356 IP 127.0.0.1.45817 > 127.0.1.1.323: UDP, length 36
      > 15:24:37.790361 IP 127.0.0.1.323 > 127.0.0.1.45817: UDP, length 32
      >
      > Which appears to be fine...?
      > There is no firewall installed on this system to my knowledge.

      Any chance the version of chronyc doesn't match the version of
      chronyd? What version are they? It looks like chronyc is getting
      responses from the server, but doesn't like them. The protocol was
      changed in 1.24, 1.27, 1.29.1.

      --
      Miroslav Lichvar

      --
      To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org
      with "unsubscribe" in the subject.
      For help email chrony-users-requ...@chrony.tuxfamily.org
      with "help" in the subject.
      Trouble?  Email listmas...@chrony.tuxfamily.org.



Reply via email to