On Fri, Apr 28, 2017 at 01:51:18PM +0100, Benjamin Schnieders wrote:
> Ohhhhh.....
> Yes, connecting to chronyd over the network worked. Next thing, I tried
> connecting to itself using -h, which worked fine. Connecting to
> itself using its hostname, however, didn't work, which finally pushed me in
> the right direction:
> in /etc/hosts, there was an entry
> localhost
> which, as we all know, is not the default address for localhost. Setting it
> to solved the issue. I guess chronyc defaults to "localhost", if
> no hostname is given. Then, I guess, in some other part of the software
> only is allowed per default; not other loopback IP addresses.

The problem is that chronyd doesn't respond to chronyc from the same
IP address as it received the request. It's in the tcpdump output you
had in the original report, but nobody noticed :).

chronyd uses IP_PKTINFO on NTP sockets, but not cmdmon sockets.
Depending on how you look at it, it's either a missing feature or bug.

> In the end, this just explains the cronyc/cronyd communication
> difficulties, right? cronyd should have still run without issues...

Now that "chronyc sources" is working, you should see if it
is synchronized to its servers. If they are not reachable, there may
be a problem with firewall (e.g. your ISP may block NTP packets).

Miroslav Lichvar

To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org 
with "unsubscribe" in the subject.
For help email chrony-users-requ...@chrony.tuxfamily.org 
with "help" in the subject.
Trouble?  Email listmas...@chrony.tuxfamily.org.

Reply via email to