Hi,

I am using chrony stable 3.1 version.

Below is my cfg:
#For GPS data feed
refclock SOCK /var/run/chrony.ttyS1.sock poll 2 refid GPS maxsamples 4 prefer
#For CAN data feed
refclock SOCK /var/run/chrony.ttyS2.sock poll 2 delay 0.5 refid CAN maxsamples 5

#target is one hop reachable
local stratum 1

keyfile /etc/chrony/chrony.keys

makestep 0.01 -1



Below is the chrony sources o/p:

210 Number of sources = 2

  .-- Source mode  '^' = server, '=' = peer, '#' = local clock.
/ .- Source state '*' = current synced, '+' = combined , '-' = not combined,
| /   '?' = unreachable, 'x' = time may be in error, '~' = time too variable.
||                                                 .- xxxx [ yyyy ] +/- zzzz
||      Reachability register (octal) -.           |  xxxx = adjusted offset,
||      Log2(Polling interval) --.      |          |  yyyy = measured offset,
||                                \     |          |  zzzz = estimated error.
||                                 |    |           \
MS Name/IP address         Stratum Poll Reach LastRx Last sample
===============================================================================
#? GPS                           0   2   377     2   -4509h[ -4509h] +/-  6567m
#? CAN                           0   2     0     -     +0ns[   +0ns] +/-    0ns


My query:
Although I have given makestep 0.01 -1 and maxsample for GPS refclock is set to 
4, I am still not able to see the synch happening.
I am feeding offset data to GPS refclock for every 1 sec.
Can you please suggest any configuration changes here. However sometimes it 
works.
Similar issue I am finding in chrony 2.2 that's where I thought of testing with 
3.1 if this has to do with some bug.

--
Thanks and Regards,
Bhushan J.

Reply via email to