Hi,

I have tested different versions and setup of chrony the last few weeks. My
goal is to get the most accurate and stable time possible from UTC using
ntp and a gps timeserver.

My setup is pretty simple, linux boxes, one switch between everything. For
my tests I am also using a third-party software as monitoring, connected
via PTP and PPS on my timeservers, which does ntp polling (with hw
timestamping) every second on the different clients and graph the offsets.

I started first with older versions of chrony (1.30) and got pretty good
results, then tried to play with client side hardware timestamping and
tested version 3.

The results with hwtimestamps were pretty good, especialy with a source
that use hw timestamps as well, showing a very steady line on my monitoring
system with a slight constant offset (+5us).. maybe due to an
asymmetry somewhere ?

However I then noticed than all my chrony 3+ clients with hardware
timestamping not enabled report suddenly an innacurate time with a constant
offset to utc (approximativly -20 to -25 usec to utc) on my monitoring
system. If i switch back to chrony 1.30, with the same configuration, the
time offset is good again.

I first thought that there was a problem on the server side of chrony, but
if I sync a 1.30 client on a 3+ client, it will report the same offset too.

Another behaviour i noticed on version 3+ with kernel timestamping is that
for some server i can have very long poll time (60 seconds) even if i
configured minpoll and maxpoll to shorter interval (0 & 1)

I tried version 2.4.1 and there are no such problem, so I assume it starts
with version 3.0. I just tested the chrony 3.2-pre2 and the problem is
still there.

Any idea where this could come from ?

Happy to provide more infos/data if needed

Reply via email to