I have a Raspberry Pi Model 2 running Raspbian Jessie. Attached to the Raspberry Pi is a GPS HAT from Adafruit. I think I have all the libs installed to get this to work, but for some reason I am getting question marks "?" when I run chronyc sources.
The goal is to get accurate time with no internet connection. The only time source is the GPS HAT.
Status printouts below.
Any hints/suggestions on getting this to work are greatly appreciated.
Thank you.
 
chronyc sources
210 Number of sources = 2
MS Name/IP address         Stratum Poll Reach LastRx Last sample               
===============================================================================
#? GPS                           0   4     0     -     +0ns[   +0ns] +/-    0ns
#? PPS                           0   4     0     -     +0ns[   +0ns] +/-    0ns
 
chronyc tracking
Reference ID    : 7F7F0101 ()
Stratum         : 8
Ref time (UTC)  : Fri Feb 02 17:23:28 2018
System time     : 0.000000004 seconds fast of NTP time
Last offset     : +0.000000000 seconds
RMS offset      : 0.000000000 seconds
Frequency       : 7.218 ppm fast
Residual freq   : +0.000 ppm
Skew            : 0.000 ppm
Root delay      : 0.000000000 seconds
Root dispersion : 0.000000000 seconds
Update interval : 0.0 seconds
Leap status     : Normal
 
systemctl status chronyd
● chronyd.service - NTP client/server
   Loaded: loaded (/lib/systemd/system/chronyd.service; enabled)
   Active: active (running) since Fri 2018-02-02 00:18:07 UTC; 17h ago
     Docs: man:chronyd(8)
           man:chrony.conf(5)
 Main PID: 961 (chronyd)
   CGroup: /system.slice/chronyd.service
           └─961 /usr/local/sbin/chronyd
 
 
-- To unsubscribe email chrony-users-requ...@chrony.tuxfamily.org with "unsubscribe" in the subject. For help email chrony-users-requ...@chrony.tuxfamily.org with "help" in the subject. Trouble? Email listmas...@chrony.tuxfamily.org.

Reply via email to