A little background, OpenSolaris (B130) using CIFS in domain mode (Win2k8).  
CIFS/ACLs based on AD Groups is working fine.  FYI, I'm pretty new to 
OpenSolaris so apologies if I don't list the necessary information.

I'm trying to figure out how to list open files on OpenSolaris and discovered 
that you should be able to use "Computer Management" on a Windows' system.  I 
was able to use Computer Management to enumerate the Shares, but receive access 
denied when trying to view Open Files or just no output.  So I wanted to add my 
domain user to either the administrators or power users group as shown by 
"smbadm show".

When I issue:
unixu...@opensolaris:# smbadm add-member -m DOMAIN/domainuser administrators"
I always get this output:
failed to add DOMAIN/domainuser: unable to obtain SID

I decided to map the domainuser to a unixuser, give that unix user some roles 
(SMB Management).  Mapping shows fine using idmap show-cv domainu...@domain.com 
and idmap dump -nv shows the mapping (not to mention the Ephemeral mappings)

Issuing, tried "smbadm add-member -m DOMAIN/user administrators" again, I get 
the same error.  So this time around I try "smbadm add-member -m 
OPENSOLARISHOST/unixuser administrators" and I get the same error.

Rebooted server (home server, so no issue rebooting), same thing.  Ran the 
check script @ 
only thing it outputs is something about not finding an instance of 'samba' 
(presumably since I'm using the native CIFS service?) and something about 
adding DOMAIN to the search entry in resolv.conf (only had domain.com in 
resolv.conf), which I've added.

I'm at a loss on what I'm doing wrong.  I've searched the Bugs site.  I found: 
http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6914411 but that 
doesn't seem to apply to what I'm seeing (I am sudo'd at the time).

PS I've also tried adding using domainu...@domain.com DOMAIN\\domainuser.
This message posted from opensolaris.org
cifs-discuss mailing list

Reply via email to