Yes, that's true, I helped develop a network test application that emulated OSPFv2 and the only place I ever saw Type-9-11 LSAs used was for RSVP-TE and P2MP-TE. Each LSA type can be used according to its LSA scope. OSPF capabilities can be used with P2MP-TE, but I haven't seen any NEMs do this yet.
I believe the two main test vendors support all three LSAs for this use. Leah From: Egor Zimin [mailto:[email protected]] Sent: Thursday, April 15, 2010 11:31 PM To: Leah Lynch (Contractor) Cc: Ovidiu Neghina; [email protected]; [email protected] Subject: Re: [c-nsp] OSPF LSA Type 11 1. RFC 3630 "Traffic Engineering (TE) Extensions to OSPF Version 2"(section 2.1) said: "..this proposal uses only Type 10 LSAs" 2. OSPFv2 LSA Type 11 can be used for: - Dynamic Hostname Exchange Mechanism for OSPF (RFC 5642) - Extensions to OSPF for Advertising Optional Router Capabilities (RFC 4970) - TE-MESH-GROUP (RFC 4972) - Inter-AS TE ( http://tools.ietf.org/html/rfc5392#section-3.1.1 ) ... 2010/4/15 Leah Lynch (Contractor) <[email protected]> Opaque LSA types 9-11 are used for TE reachability. I tried to google this, but didn't find any hits. I think the best reference for this area is Eric Osborn's RSVP-TE book, its excellent. To be honest, the best way to learn this is to try it out in a lab, it is just not very well documented. You can also try googling OSPF-TE. Here's one tiny description: http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_e xample09186a0080093fd0.shtml Leah -----Original Message----- From: [email protected] [mailto:[email protected]] On Behalf Of Ovidiu Neghina Sent: Tuesday, April 13, 2010 11:19 PM To: [email protected] Cc: [email protected] Subject: Re: [c-nsp] OSPF LSA Type 11 It is a good question. The RFC describes the scopes of the 3 opaque LSAs. LSA11 has AS scope like LSA5. Nothing related to MPLS TE though. As far as I researched and read LSA10 is used in MPLS TE. br Ovidiu On Tue, Apr 13, 2010 at 9:38 PM, Shimol Shah <[email protected]> wrote: > 5250 obsoletes 2370 > > http://tools.ietf.org/html/rfc5250 > > On 4/13/10 2:31 PM, Pritesh Patel wrote: >> >> rfc 2370. >> >> --Pritesh >> >> On Tue, Apr 13, 2010 at 11:15 AM, Ibrahim Abo Zaid >> <[email protected]> wrote: >>> >>> Hi >>> >>> i want to know the role of OSPF Opaque LSA Type 11 in MPLS TE ? >>> >>> thanks >>> _______________________________________________ >>> cisco-nsp mailing list [email protected] >>> https://puck.nether.net/mailman/listinfo/cisco-nsp >>> archive at http://puck.nether.net/pipermail/cisco-nsp/ >>> >> >> _______________________________________________ >> cisco-nsp mailing list [email protected] >> https://puck.nether.net/mailman/listinfo/cisco-nsp >> archive at http://puck.nether.net/pipermail/cisco-nsp/ > > _______________________________________________ > cisco-nsp mailing list [email protected] > https://puck.nether.net/mailman/listinfo/cisco-nsp > archive at http://puck.nether.net/pipermail/cisco-nsp/ > _______________________________________________ cisco-nsp mailing list [email protected] https://puck.nether.net/mailman/listinfo/cisco-nsp archive at http://puck.nether.net/pipermail/cisco-nsp/ This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message. _______________________________________________ cisco-nsp mailing list [email protected] https://puck.nether.net/mailman/listinfo/cisco-nsp archive at http://puck.nether.net/pipermail/cisco-nsp/ -- Best regards, Egor Zimin This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message. _______________________________________________ cisco-nsp mailing list [email protected] https://puck.nether.net/mailman/listinfo/cisco-nsp archive at http://puck.nether.net/pipermail/cisco-nsp/
