On second look,

I don’t see your routers interface (Gi0) having a native vlan to be able to 
move untagged traffic between itself and the switch. Usually ip phones get dhcp 
from data vlan.

Try changing voice subnet to something else and give x.x.15.0/24 to data vlan 
and see if that works.

Kind Regards,
Dennis


-----Original Message-----
From: Michael Ulitskiy [mailto:mulits...@acedsl.com] 
Sent: Tuesday, August 8, 2017 6:19 PM
To: Dionisios Karopoulos <d.karopou...@connecticore.com>
Cc: cisco-nsp@puck.nether.net
Subject: RE: [c-nsp] Cisco IOS DHCP server problem

Hello,

I did.  I tried to disable 'voice vlan' and put the phone in plain access vlan 
and disabled cdp.
Still the same. Phone ignores DHCPOFFER.
Any more ideas?
Thanks,

Michael

-----Original Message-----
From: Dionisios Karopoulos [mailto:d.karopou...@connecticore.com]
Sent: Tuesday, August 8, 2017 2:38 AM
To: 'Michael Ulitskiy'
Cc: cisco-nsp@puck.nether.net
Subject: RE: [c-nsp] Cisco IOS DHCP server problem

Hello,

Try disabling cdp/lldp towards the ip phone and see if it helps.

Kind Regards,
Dennis


-----Original Message-----
From: cisco-nsp [mailto:cisco-nsp-boun...@puck.nether.net] On Behalf Of Michael 
Ulitskiy
Sent: Monday, August 7, 2017 10:06 PM
To: cisco-nsp@puck.nether.net
Subject: [c-nsp] Cisco IOS DHCP server problem

Hello,



I'm sorry to ask such a probably basic question, but I'm at loss.

I have a very trivial setup: router (3825, IOS 15.0(1)M10) - switch (3750, IOS
12.2(50)SE5) - ip phone (7962, firmware SCCP42.9-3-1SR3-1S)

For some reason the phone can't get ip address and I have no clue why. It looks 
like it discards router's DHCPOFFER.

Here's what I'm getting in debugging after phone powering up:



c199-41133#

Aug  7 14:35:50: DHCPD: client's VPN is .

Aug  7 14:35:50: DHCPD: DHCPDISCOVER received from client 010c.d996.9043.99 on 
interface GigabitEthernet0/0.20.

Aug  7 14:35:50: DHCPD: Sending DHCPOFFER to client 010c.d996.9043.99 
(10.10.15.38).

Aug  7 14:35:50: DHCPD: broadcasting BOOTREPLY to client 0cd9.9690.4399.

c199-41133#

Aug  7 14:35:54: DHCPD: client's VPN is .

Aug  7 14:35:54: DHCPD: DHCPDISCOVER received from client 010c.d996.9043.99 on 
interface GigabitEthernet0/0.20.

Aug  7 14:35:54: DHCPD: Sending DHCPOFFER to client 010c.d996.9043.99 
(10.10.15.38).

Aug  7 14:35:54: DHCPD: broadcasting BOOTREPLY to client 0cd9.9690.4399.

c199-41133#

Aug  7 14:36:02: DHCPD: client's VPN is .

Aug  7 14:36:02: DHCPD: DHCPDISCOVER received from client 010c.d996.9043.99 on 
interface GigabitEthernet0/0.20.

Aug  7 14:36:02: DHCPD: Sending DHCPOFFER to client 010c.d996.9043.99 
(10.10.15.38).

Aug  7 14:36:02: DHCPD: broadcasting BOOTREPLY to client 0cd9.9690.4399.



The config is very basic, subnet is directly attached, no dhcp relays:



Router:

ip dhcp pool DHCP-VOIP

   network 10.10.15.0 255.255.255.0

   default-router 10.10.15.1

   dns-server 10.10.15.1

!

interface GigabitEthernet0/0.20

description VOIP VLAN

encapsulation dot1Q 20

ip address 10.10.15.1 255.255.255.0

no ip redirects

no ip proxy-arp

ip verify unicast source reachable-via rx 1

ip nat inside

ip virtual-reassembly

!



Switch:

interface FastEthernet2/0/8

description Universal computer/phone port

switchport access vlan 10

switchport mode access

switchport voice vlan 20

spanning-tree portfast



I did some googling, I found several people complaining about similar problem, 
but no solution.

Does anyone have any idea what might be wrong here or how to further 
troubleshoot it?

Thanks a lot,



Michael



_______________________________________________
cisco-nsp mailing list  cisco-nsp@puck.nether.net 
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Reply via email to