Hello,

It's been a few weeks I've been working on EVPNs and IOS-XR 6.1 and i
wonder if ther's a way to couple AC and PW status so that you can
propagate PE-CE link failures end-to-end.

I know it's supported for "regular" EVPNs (RFC7432), but EVPN-VPWS
(RFC8214) is definitely a special case.

Here's my configuration snippets

!
hostname XRV1
!
interface GigabitEthernet0/0/0/0.200 l2transport
 encapsulation dot1q 200
!
router bgp 64496
 bgp router-id 192.0.2.1
 address-family l2vpn evpn
 !
 neighbor 192.0.2.2
  remote-as 64496
  local address 192.0.2.1
  address-family l2vpn evpn
  !
 !
!
l2vpn
 xconnect group test
  p2p test
   interface GigabitEthernet0/0/0/0.200
   neighbor evpn evi 100 target 300 source 200
  !
 !
!


!
hostname XRV2
!
interface GigabitEthernet0/0/0/0.300 l2transport
 encapsulation dot1q 300
!
router bgp 64496
 bgp router-id 192.0.2.2
 address-family l2vpn evpn
 !
 neighbor 192.0.2.1
  remote-as 64496
  local address 192.0.2.2
  address-family l2vpn evpn
  !
 !
!
l2vpn
 xconnect group test
  p2p test
   interface GigabitEthernet0/0/0/0.300
   neighbor evpn evi 100 target 200 source 300
  !
 !
!


What i'd expect is XRV1 to turn Gi0/0/0/0.200 down when XRV2 withdraws
the BGP advertisements.

Is that supported?

Thank you

Regards


-- 
Marco
_______________________________________________
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Reply via email to