let me change the config setting in CUCM to H.323 and let you know.

thank you for your help again.


thanks

Hamu


________________________________
From: Anthony Holloway <avholloway+cisco-v...@gmail.com>
Sent: Friday, March 2, 2018 9:07 AM
To: Hamu Ebiso; Cisco VoIP Group
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router

Unfortunately, again, the number you're calling 4131, is not matching the 
dial-peers you posted; however, the debugs are still saying you're hitting DP 
5, which is an H323 DP not SIP.

On Thu, Mar 1, 2018 at 1:44 PM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:


Here is the debug output for debug voip ccapi inout, and debug ccsip messages.


Thank you again for your help.



________________________________
From: Anthony Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Thursday, March 1, 2018 1:16 PM
To: Hamu Ebiso

Cc: Cisco VoIP Group
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router
debug voip ccapi inout, and if you're using SIP, then debug ccsip messages as 
well.  the debug vpm signal is not very helpful, though it does show the port 
selected.

On Thu, Mar 1, 2018 at 1:05 PM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

Thank you Anthony very much for your help.

The 19529473283<tel:(952)%20947-3283> for  connection plar 
19529473283<tel:(952)%20947-3283> I was testing with. After changing of few 
things on the gateway, I'm now seeing different messages when I run debug. The 
calls used to ring only one time and then fast busy, now it rings twice and 
then fax busy for incoming. for outgoing, it's says calls connot be completed 
as dialed.


Attached the new logs again. I really appreciate your help.


thanks again.

Hamu


________________________________
From: Anthony Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Thursday, March 1, 2018 11:05 AM

To: Hamu Ebiso
Cc: Cisco VoIP Group
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router
According to the debug, you're calling 19529473283<tel:(952)%20947-3283>.  Is 
that correct?


Called Number=19529473283<tel:(952)%20947-3283>(TON=Unknown, NPI=Unknown),

If so, then this debug is not for this gateway, because you're hitting Outgoing 
Dial-peer=5


Outgoing Dial-peer=5, Params=0x688FF3FC, Progress Indication=ORIGINATING SIDE 
IS NON ISDN(3)

And dial-peer 5, while it exists in your config you pasted, it doesn't match 
the called number.

dial-peer voice 5 voip
 description FXO test
 destination-pattern 12083437020<tel:(208)%20343-7020>
 session target ipv4:10.0.2.5
!

Even if it did match the destination pattern, you're missing some config on 
this dial-peer to make a SIP capable dial-peer, which means it's sending H323 
setup to CUCM.  If you built the gateway as H323, then I can see how it rang 
your CIPC, otherwise, if you built it as SIP, which you said you did, then it 
would never ring your CIPC.

So, something is not adding up here.

Also, you're hitting Incoming Dial-peer=0, which on a POTS leg is not too 
terrible, but it's also not good practice to be using dial-peer 0.  It's really 
VoIP DP 0 that is messy though.


Incoming Dial-peer=0, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), 
Calling IE Present=FALSE,


On Thu, Mar 1, 2018 at 10:06 AM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

Hi Anthony,


yes the call was hitting the gateway because I was seeing FXO port going 
Off-Hook. The problem was that Logging was not setup in the gateway. After I 
setup the Logging, I'm now seeing logs.


I have attached the log.

thanks

Hamu

________________________________
From: avhollo...@gmail.com<mailto:avhollo...@gmail.com> 
<avhollo...@gmail.com<mailto:avhollo...@gmail.com>> on behalf of Anthony 
Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Thursday, March 1, 2018 8:45 AM
To: Hamu Ebiso
Cc: Cisco VoIP Group

Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router
Since you didn't see the call in your debugs, your call likely didn't hit your 
gateway.

Can you confirm how you made your test call, when you had your debug running?

On Feb 28, 2018 2:46 PM, "Hamu Ebiso" 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

Here is the dial-peer output

1#show run | sec dial-peer
dial-peer voice 1 pots
 trunkgroup FXO_EM
 translation-profile incoming Inbound
 call-block translation-profile incoming block_profile
 call-block disconnect-cause incoming call-reject
 incoming called-number .
 direct-inward-dial
dial-peer voice 911 pots
 trunkgroup FXO_EM
 description Services
 translation-profile outgoing Strip9
 destination-pattern 911
dial-peer voice 9911 pots
 trunkgroup FXO_EM
 description Services
 translation-profile outgoing Strip9
 destination-pattern 9911
dial-peer voice 2 voip
 description CUCM Dial-Peer - Inbound
 preference 1
 destination-pattern 12086858038<tel:(208)%20685-8038>
 session protocol sipv2
 session target ipv4:10.0.2.6
 incoming uri via 10
 voice-class codec 1
 dtmf-relay rtp-nte sip-kpml
 fax-relay ecm disable
 fax nsf 000000
 ip qos dscp cs3 signaling
 no vad
dial-peer voice 3 voip
 preference 2
 destination-pattern 12086858038<tel:(208)%20685-8038>
 session target ipv4:10.0.2.3
dial-peer voice 650 pots
 trunkgroup Local
 description Local outbound
 translation-profile outgoing Strip9
 destination-pattern 9208.......
dial-peer voice 4 pots
 trunkgroup FXO_EM
 description ** 10-digit Local Call **
 translation-profile outgoing Strip9
 destination-pattern ^9[2-9]..[2-9]......$
 forward-digits 10
dial-peer voice 5 voip
 description FXO test
 destination-pattern 12083437020<tel:(208)%20343-7020>
 session target ipv4:10.0.2.5


thank you very much!!

________________________________
From: Anthony Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Wednesday, February 28, 2018 1:29 PM
To: Hamu Ebiso
Cc: cisco-voip voyp list
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router

Maybe you're actually using MGCP then?  You still haven't shown the dial-peers 
on the gateway.  Is that because you don't have any?

show run | section dial-peer

On Wed, Feb 28, 2018 at 12:19 PM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

debug was turned on as shown below.


1#debug voice ccapi inout
voip ccapi inout debugging is on

made test calls and then show log, I see below output.

1#show log
Syslog logging: enabled (0 messages dropped, 37 messages rate-limited, 0 
flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.


No Inactive Message Discriminator.

    Console logging: level debugging, 517 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging:  level debugging, 550 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

    Trap logging: level debugging, 620 message lines logged
        Logging to 10.0.7.139  (udp port 514, audit disabled,
              link up),
              435 message lines logged,
              0 message lines rate-limited,
              0 message lines dropped-by-MD,
              xml disabled, sequence number disabled
              filtering disabled
        Logging to 10.0.8.12  (udp port 514, audit disabled,
              link up),
              435 message lines logged,
              0 message lines rate-limited,
              0 message lines dropped-by-MD,
              xml disabled, sequence number disabled
              filtering disabled
        Logging Source-Interface:       VRF Name:
        Loopback0


I don't see any calls activity.


thanks


________________________________
From: Anthony Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Wednesday, February 28, 2018 11:19 AM

To: Hamu Ebiso
Cc: cisco-voip voyp list
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router
But you didn't send all the information, because your output doesn't show the 
dial-peers.

One method is to capture the output from "debug voip ccapi inout" and look for 
the following line "Outgoing Dial-peer="

You also didn't address the regions either.  Can you send that too?

On Wed, Feb 28, 2018 at 11:13 AM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

I was just trying to give you all the information so that you will be able to 
see the whole picture.

Regarding your questions, I don't know how to check that.


________________________________
From: Anthony Holloway 
<avholloway+cisco-v...@gmail.com<mailto:avholloway%2bcisco-v...@gmail.com>>
Sent: Wednesday, February 28, 2018 10:45 AM

To: Hamu Ebiso
Cc: cisco-voip voyp list
Subject: Re: [cisco-voip] Need help configuring router for 911 with POTS Lines 
connected to FXO port on the router
That's interesting that I asked for the dial-peer config, and you sent 
everything but.

Do you know how to confirm which dial-peer the gateway is using?

On Wed, Feb 28, 2018 at 10:38 AM Hamu Ebiso 
<hebiso2...@hotmail.com<mailto:hebiso2...@hotmail.com>> wrote:

Below is gateway configuration




isdn switch-type primary-ni
!
!
trunk group FXO_EM
 hunt-scheme sequential
 translation-profile incoming Incoming
!
!
trunk group Local
 hunt-scheme sequential
 translation-profile outgoing outbound
!
!
trunk group LD
 translation-profile outgoing outbound
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 10.170.99.12
  ipv4 10.44.50.14
  ipv4 10.44.50.39
 no ip address trusted authenticate
 clid substitute name
 clid network-provided
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 signaling forward unconditional
 fax protocol t38 nse force version 0 ls-redundancy 0 hs-redundancy 0 fallback 
pass-through g711ulaw
 no fax-relay sg3-to-g3
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  session transport tcp
  min-se 360 session-expires 360
  ds0-num
  header-passing
  error-passthru
  registrar server expires max 600 min 60
  early-offer forced
  midcall-signaling passthru
  no call service stop
!
!
voice class uri 10 sip
 host ipv4:10.x.x.x
 host ipv4:10..x.x.x
 host ipv4:10..x.x.x
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class codec 2
 codec preference 1 g711ulaw
!
!
!
!
voice translation-rule 1
 rule 1 /^208343\(....\)$/ /1208343\1/
!
voice translation-rule 9
 rule 1 /5.../ /1208343\0/
!
voice translation-rule 10
 rule 1 /^911/ /911/
 rule 2 /^9911/ /911/
!
voice translation-rule 15
!
voice translation-rule 30
 rule 1 /^911/ /911/
 rule 2 /^9911/ /911/
 rule 4 /^9\(011.*\)/ /\1/
 rule 9 /^9\(.*\)/ /\1/
!
!
voice translation-profile Add1
 translate calling 91
 translate called 1
!
voice translation-profile Inbound
 translate called 1
!
voice translation-profile Strip9
 translate called 10
!
voice translation-profile block_profile
 translate calling 15
!
voice translation-profile outbound
 translate calling 10
!
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO3845-MB sn FOC123128X5
license accept end user agreement
archive
 log config
  hidekeys
username admin privilege 15 password 7 105D1F0C
username svuntbd privilege 15 secret 5 $1$vRxN$nu4JPZttcuPskPHoSdQZx.
!
!
controller T1 0/0/0
 shutdown
 cablelength long 0db
!
controller T1 0/1/0
 shutdown
 cablelength long 0db
!
!
!
!
!
!
interface Loopback0
 ip address 10.x.x.x 255.255.255.128
!
interface GigabitEthernet0/0
 description uplink to Lan1
 ip address 10.x.x.x 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 description uplink to Lan2
 ip address 10.x.x.x 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1
 auto-cost reference-bandwidth 10000
 network 10.0.0.0 0.0.255.255 area 10.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!


_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip

Reply via email to