> There should be a triggered update. It will list the unreachable network
> with the largest possible delay. Could you check again? Perhaps in some
> topologies, there would be no need to send a triggered update, but that
> would be strange. I think you maybe just didn't recognize it as being a
> triggered update.

I found the reason why there was no triggered updates : I used config like
this :
int eth0
 ip address 10.0.0.1 255.0.0.0
!
router igrp 10
 network 10.0.0.0
 redistribute static
ip route 1.0.0.0 255.0.0.0 Null0
ip route 2.0.0.0 255.0.0.0 Null0

I used route pointing to Null0 to simulate routes and when I suppressed a
static route, there was no triggered update.

But when I use "standard" config :

int eth0
 ip address 10.0.0.1 255.0.0.0
int eth1
 ip address 11.0.0.1 255.0.0.0
!
router igrp 10
 network 10.0.0.0
 network 11.0.0.0

When I shutdown Eth1, there's a triggered update sent through eth0 ...
So triggered updates are not generated when using redistribution (It worked
fine with RIP, so I supposed that it should work with IGRP, but no).

Thanks for your answers.

--
Stephane LITKOWSKI
Student in a French computer science school
EPITA Telecom & Network specialization
CCNA + CCNP
EMail : [EMAIL PROTECTED]



""Priscilla Oppenheimer""  a icrit dans le message
news: [EMAIL PROTECTED]
> At 03:27 PM 4/17/02, Stephane LITKOWSKI wrote:
> >Hi all,
> >
> >I have some questions about IGRP :
> >
> >- In an update, IGRP distinguish Subnets, AS Networks and outside-AS
> >networks, when I take some traces, I can see that there's the number of
each
> >category and then all routing entries but I don't understand how IGRP
know
> >if the routing entry is Subnet, AS or outside AS. Distinguishing AS
routes
> >(major net) or subnets is not important (applying interface mask and
> >comparing major networks can do distinction), but how IGRP knows if the
> >routing entry is candidate default ?
>
> An IGRP update message has three portions: interior, system (meaning "this
> autonomous system" but not interior), and exterior. (Sniffer uses slightly
> different terminology.) The interior section is for routes to subnets for
> the network on which the broadcast is being sent.
>
> Major networks (i.e. non-subnets) are put into the system portion of the
> update message unless they are exterior.
>
> A network will be flagged as exterior if it was learned from another
router
> and the information arrived in the exterior portion of the update message.
>
> Exterior routes are also "candidate defaults." They are routes that go to
> or through routers that are considered to be appropriate as defaults, to
be
> used when there is no explicit route to a destination. Cisco's
> implementation chooses a default route by picking the exterior route with
> the smallest metric.
>
>
> >- I can see in traces that IP addresses are coded with just 3 bytes, so I
> >think I cannot use subnets > 24 bits ... isn't it ?
>
> Not necessarily. Class C subnets could be greater than 24.
>
> With interior routes, a router can assume that the first octet is the same
> as the first octet of the sending and receiving interfaces, so it can be
> left out. Remember that IGRP is classful, so there's no way the prefix
> boundary could be over to the left past the 8-bit boundary, so IGRP leaves
> out the first 8 bits in interior (subnet) routes. Check your traces again.
> I think you'll see that it's the first octet (not the last) that is left
> out on interior routes.
>
> On system and exterior, which deal with major network numbers, the router
> can leave out the last octet.
>
>
> >- I can see different routing entry types, for example (traces done with
NAI
> >Sniffer Pro) :
> >
> >ROUTING ENTRY #1
> >  IP Address = [172.16.1.0]
> >  ...
> >
> >ROUTING ENTRY #2
> >  IP Address = [10.0.0.XX]
> >...
> >
> >what does the XX mean ??? I can see in hexa dump that's 00
>
> Which kind was this? System or exterior I would guess. Perhaps the XX just
> means anything (wildcard). It's probably not actually in the hex dump,
> since IGRP just uses 24 bits as you mentioned. Check for 0A 00 00, which
> would be 10.0.0.
>
>
> >- What is the utility of the hopcount ? preventing from loop like in RIP
?
>
> Yes, it prevents loops. I think if the router sees the hop count
> increasing, it puts the route in holddown.
>
> >(so is the hop count incremented hop by hop ?)
>
> Yes.
>
>
> >- I saw that Cisco implement trigger updates in IGRP, but on a Cisco
1603R
> >with IOS 12.0(4)T, it don't seem to be implemented, when there's a change
in
> >topology, there's no trigger update. Does anyone experienced this problem
?
>
> There should be a triggered update. It will list the unreachable network
> with the largest possible delay. Could you check again? Perhaps in some
> topologies, there would be no need to send a triggered update, but that
> would be strange. I think you maybe just didn't recognize it as being a
> triggered update.
>
>
> >- Does IGRP use a database like RIP ? or not ?
>
> It probably uses something like a database. For some reason, there aren't
> very good show commands for igrp though. Of course there's show ip route
> and show ip route igrp, but I don't know of others.....
>
> By the way, when trying to figure out IGRP, I go to this old paper here:
>
> http://www.cisco.com/warp/public/103/5.html
>
> Hope that helps.
>
> Priscilla
>
> >Can I see the database like
> >"show ip rip database" ?
> >
> >
> >thanks a lot.
> >
> >
> >Stephane
> ________________________
>
> Priscilla Oppenheimer
> http://www.priscilla.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=41975&t=41763
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to