On Fri, 1 Aug 2025 07:14:00 GMT, Prasanta Sadhukhan <psadhuk...@openjdk.org> 
wrote:

>> src/java.desktop/share/classes/javax/swing/JList.java line 2512:
>> 
>>> 2510:      * @return the "unit" increment for scrolling in the specified 
>>> direction;
>>> 2511:      *         which is usually positive. But it can return 0
>>> 2512:      *         if {@code visibleRect} points to that row
>> 
>> should it be `the` or `that` ?
>> Suggestion:
>> 
>>      *         if {@code visibleRect} points to the row
>> 
>> 
>> Requires a CSR too ?
>
> it is "that" row being pointed to by visibleRect
> and yes CSR is needed but I want to finalise the wordings first.

@prrace Can we just say "it will return >=0" or "it will return a non-negative 
number" instead of explaining when, as it might be delving into implementation 
details?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/26500#discussion_r2255926752

Reply via email to