Hi,

I just used ProcessorCount.cmake the first time.
I noticed a small issue:
AFAIK module file names in cmake use CamelCase, while the macros/functions use 
underscores: SomeCoolStuff.cmake -> some_cool_stuff()

ProcessorCount.cmake doesn't do this, the function is named processorcount()

IMO we should keep it this way, since it is defacto-standard, and it also 
makes sense, since I always recommend to use all-lower-caps style for 
commands, or at least all-upper-caps.
And when using all-lower, the function name is not that easy to read anymore.

So, should I rename it to processor_count() and add a processorcount() for 
backward compatibility ?

Alex

P.S. it is similar with ExternalPackage.cmake, externalproject_add() doesn't 
use the old style, it would have been external_project_add() instead.
--

Powered by www.kitware.com

Visit other Kitware open-source projects at 
http://www.kitware.com/opensource/opensource.html

Please keep messages on-topic and check the CMake FAQ at: 
http://www.cmake.org/Wiki/CMake_FAQ

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/cgi-bin/mailman/listinfo/cmake-developers

Reply via email to