When setting CMAKE_OSX_SYSROOT to the unversioned directory name
(using Xcode 8, as it happens) and setting
CMAKE_OSX_DEPLOYMENT_TARGET, I get this error:

-- The CXX compiler identification is AppleClang 8.0.0.8000038
 CMake Error at
/Applications/CMake.app/Contents/share/cmake-3.6/Modules/Platform/Darwin.cmake:76
(message):
 CMAKE_OSX_DEPLOYMENT_TARGET is '10.10' but CMAKE_OSX_SYSROOT:

 
"/Applications/Xcode-8.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk"

 is not set to a MacOSX SDK with a recognized version. Either set
 CMAKE_OSX_SYSROOT to a valid SDK or set CMAKE_OSX_DEPLOYMENT_TARGET
to
 empty.
 Call Stack (most recent call first):
 
/Applications/CMake.app/Contents/share/cmake-3.6/Modules/CMakeSystemSpecificInformation.cmake:36
(include)
 CMakeLists.txt:37 (project)

I'm able to suppress the error by using the versioned (symlink)
directory; but isn't the premise of this error message invalid? As I
understand it, since Xcode 7 (or perhaps earlier?), there is no
requirement that the deployment target match the SDK version.

Braden


-- 

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: 
http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more 
information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at 
http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/cmake

Reply via email to