> use devm_platform_ioremap_resource_byname() to simplify code,
> it contains platform_get_resource_byname() and
> devm_ioremap_resource(), and also remove some duplicate error
> message.

How do you think about a wording variant like the following?

   Use the function “devm_platform_ioremap_resource_byname” to simplify
   source code which calls the functions “platform_get_resource_byname”
   and “devm_ioremap_resource”.
   Remove also a few error messages which became unnecessary with this
   software refactoring.

Will any more contributors get into the development mood to achieve
similar collateral evolution by the means of the semantic patch language?
Would you like to increase applications of the Coccinelle software?

Cocci mailing list

Reply via email to