On 5 Apr 2013, at 14:55, Pax <45rpmli...@googlemail.com> wrote:

> On 5 Apr 2013, at 14:20, Mike Abdullah <cocoa...@mikeabdullah.net> wrote:
> 
>> 
>> For a start, trying to access instance variables directly is almost always a 
>> bad idea. Expose proper accessor methods instead.
>> 
> Why is it a bad idea?  I do this quite often, and I find it has the double 
> benefit of improving readability and reducing the number of lines of code.  
> But if it's bad then I shall look to mend my ways - but I'll need to 
> understand the badness first!

The reason it's a bad idea is because it means that you have two strongly 
coupled components of code.  You can not change the implementation of the class 
with the ivar, without also changing the implementation of the other class now.

I don't really understand your argument about lines of code or readability, you 
would be replacing

someObject->someIvar = 56.9f;

with

someObject.someProperty = 56.9f;

and

{
    float someIvar;
}

with

@property (assign, nonatomic) float someProperty;

So neither is really true.

Thanks

Tom Davie
_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to