ovidiu 02/04/09 17:42:54 Modified: src/scratchpad/schecoon/src/org/apache/cocoon/components/flow/javascript system.js Log: Rename forwardTo() to sendPage(). Removed old sendPage() as we no longer make use of named resources from the sitemap to generate output. Revision Changes Path 1.8 +3 -11 xml-cocoon2/src/scratchpad/schecoon/src/org/apache/cocoon/components/flow/javascript/system.js Index: system.js =================================================================== RCS file: /home/cvs/xml-cocoon2/src/scratchpad/schecoon/src/org/apache/cocoon/components/flow/javascript/system.js,v retrieving revision 1.7 retrieving revision 1.8 diff -u -r1.7 -r1.8 --- system.js 9 Apr 2002 05:35:02 -0000 1.7 +++ system.js 10 Apr 2002 00:42:54 -0000 1.8 @@ -16,22 +16,14 @@ return func.apply(this, args); } -function sendPage(pipelineName, pipelineArgs, bizData) +function sendPage(uri, bizData, timeToLive) { var k = new Continuation(); - var kont = new WebContinuation(cocoon, k, lastContinuation); - cocoon.processPipeline(pipelineName, pipelineArgs, bizData, kont); - lastContinuation = kont; - suicide(); -} - -function forwardTo(uri, bizData) -{ - var k = new Continuation(); - var kont = new WebContinuation(cocoon, k, lastContinuation); + var kont = new WebContinuation(cocoon, k, lastContinuation, timeToLive); cocoon.forwardTo(uri, bizData, kont); lastContinuation = kont; suicide(); + return kont; } function handleContinuation(kont)
---------------------------------------------------------------------- In case of troubles, e-mail: [EMAIL PROTECTED] To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]