Script 'mail_helper' called by obssrc
Hello community,

here is the log from the commit of package kanidm for openSUSE:Factory checked 
in at 2026-08-02 23:14:14
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kanidm (Old)
 and      /work/SRC/openSUSE:Factory/.kanidm.new.16738 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kanidm"

Sun Aug  2 23:14:14 2026 rev:68 rq:1369044 version:1.11.0~git0.ed10baa49

Changes:
--------
--- /work/SRC/openSUSE:Factory/kanidm/kanidm.changes    2026-06-23 
17:42:45.722257022 +0200
+++ /work/SRC/openSUSE:Factory/.kanidm.new.16738/kanidm.changes 2026-08-02 
23:14:47.329025570 +0200
@@ -1,0 +2,96 @@
+Sun Aug 02 02:59:39 UTC 2026 - [email protected]
+
+- Update to version 1.11.0~git0.ed10baa49:
+  * Release 1.11.0
+  * SCIM Filter Recursion Limit
+  * Update Cargo.lock
+  * Release 1.11.0-pre
+  * 20260730 pre release (#4492)
+  * Use rfc7662 token verification to ensure that the session returned (#4369)
+  * 20260701 application password cli (#4454)
+  * Add a minimal templating system that is safe for user defined templates.
+  * 20260710 radius tlscache (#4464)
+  * Refactor async task startup to improve early server stops (#4468)
+  * 20260721 actor framework (#4481)
+  * Update crypto glue (#4478)
+  * Bump pymdown-extensions in /pykanidm in the uv group across 1 directory 
(#4488)
+  * Bump the all group across 1 directory with 12 updates (#4487)
+  * Bump the all group in /rlm_python with 2 updates (#4485)
+  * Bump actions/setup-python from 6 to 7 in the all group (#4486)
+  * Properly use the Json type so that response headers are set correctly 
(#4480)
+  * Update and improve AI policy to be clearer (#4479)
+  * Bump the all group in /rlm_python with 3 updates (#4475)
+  * Bump the all group with 11 updates (#4476)
+  * 20260702 syntax tidying (#4439)
+  * Show sccache stats (#4471)
+  * 20260516 oauth2 tester (#4349)
+  * Improve handling of alerts in cred update dialog (#4338)
+  * Allow service account managers to search relevant attributes (#4381)
+  * Allow custom radius reply attributes (#4370)
+  * Drop mimalloc on linux (#4469)
+  * Fix ci errors (#4472)
+  * Fix up incorrect documentation information (#4437)
+  * 20260602 pam env (#4413)
+  * Fixing the pre-release docs (#4379)
+  * Regression test for #4460 and cleaning up error handling a bit in 
mail-sender (#4463)
+  * 20260716 clippy (#4465)
+  * Include socks feature in reqwest (#4461)
+  * feat: add live server password feedback (#4348)
+  * Bump the all group across 1 directory with 12 updates (#4456)
+  * Bump the all group in /rlm_python with 3 updates (#4459)
+  * Limit password max length (#4442)
+  * Bump joserfc in /pykanidm in the uv group across 1 directory (#4447)
+  * Bump the all group in /rlm_python with 2 updates (#4423)
+  * Fix incorrect logic in bindmount processing (#4433)
+  * Missing attributes in migration access (#4387)
+  * Typo (#4374)
+  * Update ldap3/lber to 0.8.0 (#4412)
+  * tools/cli: Rename `u2fhid` to `mozilla`. (#4411)
+  * Bump actions/checkout from 6 to 7 in the all group (#4409)
+  * Bump the all group in /rlm_python with 3 updates (#4408)
+  * Bump the all group with 5 updates (#4410)
+  * fix: log IDs for otel LDAP requests (#4373)
+  * Add serde alias for bindmount (#4398)
+  * Bump the uv group across 1 directory with 2 updates (#4403)
+  * Bump the all group with 4 updates (#4402)
+  * Bump the all group in /rlm_python with 3 updates (#4401)
+  * 20260612 clarify ai content (#4399)
+  * Bump aiohttp in /pykanidm in the uv group across 1 directory (#4386)
+  * Bump the all group in /rlm_python with 2 updates (#4389)
+  * Bump the all group across 1 directory with 11 updates (#4390)
+  * docs: clarify and extend opkssh example (#4385)
+  * OAuth2 Hardening (#4380)
+  * Avoid LSE instructions in arm64 Linux builds (#4372)
+  * Bump the all group in /rlm_python with 2 updates (#4376)
+  * fix: Return unique LDAP attributes (#4364)
+  * Bump the all group across 1 directory with 2 updates (#4362)
+  * Bump the all group with 8 updates (#4363)
+  * 20260507 schema in memory (#4315)
+  * Add max_age / improve prompt=login - now without grace periods!  (#4336)
+  * Bump the uv group across 1 directory with 2 updates (#4358)
+  * Resolve incorrect login in commited flag
+  * Bump urllib3 in /pykanidm in the uv group across 1 directory (#4355)
+  * Bump the uv group across 1 directory with 4 updates (#4341)
+  * Bump the all group across 1 directory with 17 updates (#4354)
+  * Bump the all group in /rlm_python with 3 updates (#4353)
+  * Prevent migration double-deletes
+  * Security - CRITICAL - authenticated user privilege escalation
+  * Refactor modification access paths to remove duplication
+  * Revert ClientID header (#4334)
+  * Bump the all group in /rlm_python with 2 updates (#4326)
+  * Allow SMTP urls in mail-sender (#4335)
+  * I got a bee in my bonnet (#4333)
+  * Bump actions/dependency-review-action from 4 to 5 in the all group (#4327)
+  * Add missing `/sbin/kanidm-mail-sender` (#4323)
+  * Remove debug symbols in release builds. (#4319)
+  * Rust FreeRADIUS module (#4179)
+  * Fix inconsistent flag documentation: send-reset-token (#4316)
+  * Removing npm usage and replacing with pnpm (#4313)
+  * Fix copy in TOTP removal prompt and align TOTP case (#4314)
+  * Group UI polish (#4285)
+  * Resolve base64 encoding of webauthn fields (#4312)
+  * Upgrade to v1.11.0-dev (#4305)
+  * Update ty requirement in /rlm_python in the all group (#4307)
+  * Bump the all group with 5 updates (#4308)
+
+-------------------------------------------------------------------

Old:
----
  kanidm-1.10.4~git0.97b1edbc4.tar.zst

New:
----
  kanidm-1.11.0~git0.ed10baa49.tar.zst

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kanidm.spec ++++++
--- /var/tmp/diff_new_pack.HmJY7q/_old  2026-08-02 23:14:49.677106277 +0200
+++ /var/tmp/diff_new_pack.HmJY7q/_new  2026-08-02 23:14:49.677106277 +0200
@@ -32,7 +32,7 @@
 %endif
 
 Name:           kanidm
-Version:        1.10.4~git0.97b1edbc4
+Version:        1.11.0~git0.ed10baa49
 Release:        0
 Summary:        A identity management service and clients.
 License:        ( Apache-2.0 OR BSL-1.0 ) AND ( Apache-2.0 OR ISC OR MIT ) AND 
( Apache-2.0 OR MIT ) AND ( Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT 
) AND ( CC0-1.0 OR Apache-2.0 ) AND ( MIT OR Apache-2.0 OR Zlib ) AND ( 
Unlicense OR MIT ) AND ( Zlib OR Apache-2.0 OR MIT ) AND Apache-2.0 AND 
BSD-2-Clause AND BSD-3-Clause AND CC0-1.0 AND ISC AND MIT AND MPL-2.0 AND 
MPL-2.0+

++++++ _service ++++++
--- /var/tmp/diff_new_pack.HmJY7q/_old  2026-08-02 23:14:49.725107927 +0200
+++ /var/tmp/diff_new_pack.HmJY7q/_new  2026-08-02 23:14:49.729108064 +0200
@@ -3,7 +3,7 @@
     <param name="url">https://github.com/kanidm/kanidm.git</param>
     <param name="versionformat">@PARENT_TAG@~git@TAG_OFFSET@.%h</param>
     <param name="scm">git</param>
-    <param name="revision">1.10.0</param>
+    <param name="revision">1.11.0</param>
     <param name="match-tag">v*</param>
     <param name="versionrewrite-pattern">v(\d+\.\d+\.\d+)</param>
     <param name="versionrewrite-replacement">\1</param>

++++++ _servicedata ++++++
--- /var/tmp/diff_new_pack.HmJY7q/_old  2026-08-02 23:14:49.749108752 +0200
+++ /var/tmp/diff_new_pack.HmJY7q/_new  2026-08-02 23:14:49.753108889 +0200
@@ -1,6 +1,6 @@
 <servicedata>
 <service name="tar_scm">
                 <param name="url">https://github.com/kanidm/kanidm.git</param>
-              <param 
name="changesrevision">97b1edbc4183084e1a942823d867bed0fd73e0c9</param></service></servicedata>
+              <param 
name="changesrevision">ed10baa494adc1549c2e9e3d750465cc1052a7d1</param></service></servicedata>
 (No newline at EOF)
 

++++++ kanidm-1.10.4~git0.97b1edbc4.tar.zst -> 
kanidm-1.11.0~git0.ed10baa49.tar.zst ++++++
/work/SRC/openSUSE:Factory/kanidm/kanidm-1.10.4~git0.97b1edbc4.tar.zst 
/work/SRC/openSUSE:Factory/.kanidm.new.16738/kanidm-1.11.0~git0.ed10baa49.tar.zst
 differ: char 7, line 1

++++++ vendor.tar.zst ++++++
/work/SRC/openSUSE:Factory/kanidm/vendor.tar.zst 
/work/SRC/openSUSE:Factory/.kanidm.new.16738/vendor.tar.zst differ: char 7, 
line 1

Reply via email to