Script 'mail_helper' called by obssrc
Hello community,

here is the log from the commit of package rustup for openSUSE:Factory checked 
in at 2026-08-14 22:05:44
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rustup (Old)
 and      /work/SRC/openSUSE:Factory/.rustup.new.1258 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rustup"

Fri Aug 14 22:05:44 2026 rev:29 rq:1370931 version:1.29.0~0

Changes:
--------
--- /work/SRC/openSUSE:Factory/rustup/rustup.changes    2026-07-08 
17:39:19.355294263 +0200
+++ /work/SRC/openSUSE:Factory/.rustup.new.1258/rustup.changes  2026-08-14 
22:05:55.983758483 +0200
@@ -1,0 +2,547 @@
+Thu Aug 13 04:15:05 UTC 2026 - William Brown <[email protected]>
+
+- bsc#1274144 - CVE-2026-25541 - integer overflow in 'BytesMut:reserve' can 
lead to undefined behavior and crashes
+
+-------------------------------------------------------------------
+Fri Aug 07 02:12:54 UTC 2026 - [email protected]
+
+- bsc#1274144 - CVE-2026-25541 - bytes: integer overflow in 'BytesMut:reserve' 
can lead to undefined behavior and crashes
+- Update to version 1.29.0~0:
+  * chore(deps): update `aws-lc-rs` and `aws-lc-sys`
+  * docs(changelog): update release date for v1.29.0
+  * dist(rustup-init/sh): update commit shasum in help string
+  * docs(dev-guide/release-process): mention the CfT blog post
+  * docs(changelog): update for v1.29.0 stable release
+  * fix(cli): Style CLI errors in init mode
+  * test: Add unknown arg init test
+  * chore(deps): lock file maintenance
+  * chore(deps): update actions/upload-artifact action to v7
+  * refactor(www): simplify instruction css selector
+  * feat(www): make copy button dark mode-aware
+  * feat(www): move feedback text out of copy button
+  * fix(www): apply filter to rust logo
+  * feat(www): add dark mode
+  * refactor(www): extract css variables
+  * fix(cli/self-update): enforce a newline after `check_updates()`
+  * refactor(cli/self-update): extract `has_progress_bars` in `check_updates()`
+  * fix(cli/self-update): unify `check_*update*()`'s message formats
+  * docs(downloads): fix the default number of `RUSTUP_CONCURRENT_DOWNLOADS`
+  * feat(toolchain): add `--override` to override toolchain as soon as 
installed
+  * fix(toolchain): improve logs when recovering from an interrupted 
installation
+  * chore(deps): lock file maintenance
+  * chore(deps): downgrade `openssl-src` to 300.5.4+3.5.4
+  * style(download): clean up imports
+  * fix(diskio): fall back to single-threaded unpacking when `ram_budget` < 
512MB to avoid OOM on memory-constrained systems
+  * test(downloads): check if an error is thrown if the server does not honor 
range
+  * fix(downloads): check correct response when resuming from partial (reqwest)
+  * fix(downloads): check correct response when resuming from partial (curl)
+  * fix(deps): update rust crate toml to v1
+  * chore(deps): lock file maintenance
+  * fix(dist/manifest): sort keys when serializing `Manifest`
+  * hack(ci/linux): disable BuildKit when building local images
+  * chore(ci): use more distinctive local image names
+  * Upgrade rand to 0.10
+  * Upgrade snapbox to 1
+  * Upgrade to anstream 1
+  * fix(downloads): adjust error message for partial files in network failures
+  * test(downloads): ensure that partial files are not removed when network 
fails
+  * feat(downloads): do not delete partial download when network fails
+  * fix(downloads): substitute `DEK` alias for `DownloadError`
+  * chore(deps): lock file maintenance
+  * chore(deps): lock file maintenance
+  * chore(deps): update aws-actions/configure-aws-credentials action to v6
+  * Take semver-compatible dependency updates
+  * cli: introduce semantic exit code constants for rustup check
+  * Add missing Windows SDK instructions
+  * Add winget instructions to MSVC install page
+  * Remove nu-string-interpolation `$`
+  * Replace $nu.home-path with ~
+  * feat(cli/rustup-mode): add "Exit status" section to `rustup check --help`
+  * chore(deps): lock file maintenance
+  * Add common commands section in help text
+  * fix(cli/rustup-mode): improve exit code of `rustup check`
+  * refactor(test)!: pass status code directly to `SanitizedOutput`
+  * chore(deps): lock file maintenance
+  * Add powerpc64-unknown-linux-musl support
+  * fix: add copy_file_symlink_to_source for self-installation
+  * fix: preserve symlinks in copy_dir instead of following them
+  * feat(cli/rustup-mode): add `doc --rustc-docs` to open rustdoc for Rust 
internals
+  * Remove the mixed singular/plural phrasing as "component(s)" instead, use 
"components" or "component". In the singular case also add the name of the 
component for more consistent messaging style with other info! outputs about 
single components.
+  * fix(cli/rustup-mode): `check` for self updates for 
`SelfUpdateMode::CheckOnly`
+  * test: Add test for sequential multi-toolchain uninstall
+  * fix: directory removal race condition in toolchain uninstall
+  * chore(deps): lock file maintenance
+  * test(cli_v2): test error when missing many components on install
+  * fix(dist): adjust printed newlines in `components_missing_msg()`
+  * unified nightly disclaimer wording/styling; preserved distinct messages 
per scenario
+  * chore(deps): lock file maintenance
+  * Upgrade to reqwest 0.13
+  * chore(deps): lock file maintenance
+  * change test name to match new terminology
+  * rename file to match new terminology
+  * change 'target triple' to 'target tuple'
+  * chore(deps): lock file maintenance
+  * fix(toolchain): forbid toolchain names starting with +
+  * cli: add `doc --releases` to open release notes
+  * chore(deps): update actions/upload-artifact action to v6
+  * chore(deps): update actions/cache action to v5
+  * chore(deps): lock file maintenance
+  * dist: use more concise API in helper function
+  * dist: inline more logic into helper function
+  * dist: give helper function a more meaningful name
+  * dist: move helper function closer to usage site
+  * docs(dev-guide): mention snapshot updating in release process
+  * fix(toolchain): avoid unwrapping when parsing a toolchain name
+  * fix(toolchain): change regex to reject leading zeros in toolchain name
+  * dist(rustup-init/sh): update commit shasum in help string
+  * docs(changelog): update for v1.29.0 beta release
+  * dist: bump `rustup` version to v1.29.0
+  * docs(changelog): add missing link references
+  * test(static-roots): use a more compact syntax for raw binaries
+  * test(static-roots): return `Result` from `store_static_roots()`
+  * download: statically bundle relevant trust anchors
+  * chore(deps): lock file maintenance
+  * Added xonsh support
+  * chore(deps): lock file maintenance
+  * refactor(dist/manifestation): remove redundant redeclarations
+  * docs(dist/download): remove outdated note on concurrent download progress 
reporting
+  * fix(dist/download): align `total_bytes` fields in progress reporting UI
+  * fix: default to GNU host in Cygwin/MSYS/MinGW environments (#4221)
+  * chore(config): remove redundant imports
+  * fix(dist/manifestation): print "downloading component" only on 
`InstallEvents`
+  * fix(utils): downgrade panic to warning in 
`delete_dir_contents_following_links()`
+  * chore(deps): update actions/checkout action to v6
+  * chore(deps): lock file maintenance
+  * Prepare for mdbook 0.5 migration
+  * dist: make installation asynchronous
+  * dist: make installations 'static
+  * dist: take ownership of Manifestation
+  * dist: store owned temp::Context in Transaction
+  * dist: store temp::Context in DownloadCfg
+  * dist: align progress bar elements
+  * dist: track progress during unpacking
+  * utils: drop unused reader tracking
+  * process: fix refresh rate for progress bars
+  * process: reduce duplication in ProgressDrawTarget setup
+  * Yield references from Manifest::short_name()
+  * Move Component name helpers to Manifest
+  * chore(deps): lock file maintenance
+  * dist: simplify ComponentBinary construction
+  * dist: hoist creation of io_executor some more
+  * Move unpack_ram() from dist to diskio
+  * dist: hoist Executor creation up
+  * dist: inline effective RAM limit calculation
+  * dist: hoist environment variable extraction
+  * dist: use logging for missing parent warnings
+  * dist: clarify dependency on unpack RAM budget
+  * diskio: clarify dependency on I/O thread count
+  * dist: transfer ownership of component values
+  * dist: take ownership of existing Components
+  * dist: take ownership of toolchain name in update()
+  * dist: take ownership of manifest in update()
+  * dist: derive trivial initialization for Update
+  * dist: rename Update::build_update() to new()
+  * dist: linearize for-loop in Update::build_update()
+  * dist: inline single-use function
+  * dist: inline trivial helper function
+  * dist: inline single-use tranaction change helpers
+  * dist: store specific config bit in Transaction
+  * chore(config): migrate config .github/renovate.json
+  * chore(deps): lock file maintenance
+  * dist: attach manifest download functions to DownloadCfg
+  * rustup: unhide top-level install/uninstall commands
+  * dist: move update_from_dist() to DistOptions::install_into()
+  * Be more consistent about aliases for different subcommands
+  * chore(deps): lock file maintenance
+  * test: add test for `rustup toolchain install --no-update`
+  * feat(rustup-mode): add `no_update` flag to `rustup toolchain install`
+  * cli: prepare DistOptions in advance
+  * dist: inline trivial wrapper function
+  * cli: inline single-use update_all_channels() helper
+  * config: simplify update_all_channels()
+  * dist: deduplicate DistOptions initialization
+  * dist: avoid recomputing dist root URL
+  * dist: simplify tracing instrumentation
+  * install: take ownership in InstallMethod::install()
+  * dist: move DistributableToolchain::install() up
+  * dist: clarify when update_hash is available
+  * cli: avoid dropped temporary
+  * Take semver-compatible dependencies
+  * dist: install while downloading
+  * dist: store more context in ComponentBinary
+  * dist: yield self when download is complete
+  * dist: move URL alteration logic into DownloadCfg method
+  * Apply suggestions from clippy 1.91
+  * refactor(check): Consolidate use_colors checks
+  * fix(check): Use Cargo's colors
+  * refactor(check): Make calls more consistent
+  * dist: drop another layer of abstraction
+  * dist: store package directory once
+  * dist: inline short single-use function
+  * dist: discard unnecessary abstraction layer
+  * chore(deps): update actions/upload-artifact action to v5
+  * chore(deps): lock file maintenance
+  * fix(cli/rustup-mode): add missing self-update in `rustup toolchain install`
+  * refactor(cli/self-update): move `self_update()` to 
`SelfUpdateMode::update()`
+  * refactor(cli/rustup-mode): pass self-update predicates into `self_update()`
+  * refactor(cli/self-update): import `utils::ExitCode`
+  * rustup: tweak update check output style
+  * fix(list): Match show command's styling
+  * test(list): Add UI test
+  * fix(toolchain): Have 'list' match 'show's styling
+  * refactor(toolchain): Order logic by display order
+  * refactor(toolchain): Use string interpolation
+  * test(toolchain): Show list's behavior
+  * fix(update): Match 'cargo update's colors
+  * refactor(update): Centralize style knowledge
+  * test: Cover different show_channel_update cases
+  * fix(check): Subject check to RUSTUP_TERM_COLOR
+  * test(check): Show current style
+  * fix: Use HEADER styling in 'rustup show'
+  * chore: Update clap-cargo
+  * test: Demonstrate show's behavior
+  * test(process): Allow forcing color on
+  * test(process): Ensure non-locked writes are stripped of ANSI escape codes
+  * cli: update `uninstall_removes_source_from_rcs` to mirror 
`uninstall_doesnt_modify_rcs_with_no_modify_path`
+  * cli: add tests for `rustup self uninstall --no-modify-path`
+  * cli: add `rustup self uninstall --no-modify-path`
+  * cli: add help text for `rustup self uninstall -y`
+  * fix(cli/help): change indentation of discussions to 2 spaces
+  * fix(cli/help): adjust help text for `rustup install`
+  * feat(cli/help): add toolchain install tips to `rustup update`'s discussion
+  * feat(cli/help): discuss `rustup toolchain install`
+  * style: Remove wildcard imports
+  * progress: modify progress bar's states to be column-aligned
+  * installations: handle installation of components through progress bars
+  * feat(cli): Add a sub-heading style for 'completion' Help Discussion
+  * feat(cli): Have Help Discussions match rest of CLI Help
+  * feat(cli): Add color to clap help/errors
+  * refactor(cli): Switch help text to functions
+  * chore(deps): lock file maintenance
+  * cli: propagate ActiveSource from the top
+  * cli: upgrade error events to ERROR level
+  * cli: inline Cfg::active_rustc_version()
+  * cli: extract display_version() from rustup main()
+  * cli: inline Cfg::resolve_local_toolchain()
+  * cli: inline Cfg::resolve_toolchain()
+  * config: extract setting of toolchain override in rustup help mode
+  * cli: avoid Cfg construction indirection
+  * config: privatize some Cfg fields
+  * config: drop trivial Cfg setters
+  * Expand `RUSTUP_TOOLCHAIN_SOURCE`'s documentation
+  * refactor(installation): extract installation of a component into a 
separate function
+  * bin: clean up imports
+  * cli: rename CLIError to CliError
+  * config: rename OverrideDB to OverrideDb
+  * dist: clean up unnecessary qualification
+  * test: Replace trycmd with snapbox
+  * chore: Update snapbox
+  * Update the default Windows SDK version
+  * refactor(log): Single source RUSTUP_TERM_COLOR
+  * style: Encourage using existing imports
+  * process: avoid fine-grained locking for logs
+  * process: discard unnecessary layer of synchronization
+  * process: inline TerminalInnerLocked
+  * process: replace unsafe code with safe equivalent
+  * process: extract color_choice() method
+  * process: extract is_a_tty value
+  * process: inline StreamSelector::is_a_tty()
+  * process: inline TestWriterLock
+  * Implement `RUSTUP_TOOLCHAIN_SOURCE` with new `Display` impl
+  * Move `Display` impl to `to_reason()`
+  * Rename `ActiveReason` to `ActiveSource`
+  * dist: simplify DownloadStatus setup
+  * dist: decentralize download status
+  * dist: postpone creation of ComponentBinary values
+  * dist: extract DownloadStatus type
+  * dist: call DownloadTracker methods directly
+  * dist: drop unnecessary Notifier layer
+  * dist: replace PackageContext with DownloadCfg
+  * refactor: Directly apply styling
+  * refactor: Don't bother grabbing lock for tests
+  * refactor: Replace termcolor with anstream
+  * refactor: Move style building out of ColorableTerminal
+  * refactor: Migrate to anstyle for color definitions
+  * fix(www): removes www subdomain from all rust-lang.org urls
+  * chore(deps): lock file maintenance
+  * dist: move Notification into dist::download
+  * notifications: remove unused Display impl
+  * dist: move Notifier into DownloadCfg
+  * cli: build Cfg earlier in setup mode
+  * dist: reuse existing DownloadCfg in update_v1()
+  * dist: move dist_root out of DownloadCfg
+  * dist: drop unused Clone derives
+  * dist: drop Copy derive from DownloadCfg
+  * dist: move Notifier and DownloadTracker into dist::download
+  * dist: inline DownloadCfg test setup
+  * download: move File items down
+  * download: extract DownloadCfg initialization from Cfg
+  * config: discard pointless method argument
+  * cli: rename DownloadTracker::new_with_display_progress() to new()
+  * notifications: log directly from DownloadTracker
+  * notifications: log directly on bad download checksums
+  * notifications: log directly when reusing downloaded files
+  * notifications: log directly on buffer size changes
+  * Update platforms to 3.7.0
+  * notifications: log directly on duplicate toolchain files
+  * notifications: log directly on metadata upgrades that remove toolchains
+  * notifications: log directly when reading metadata version
+  * notifications: log directly when metadata upgrade is not needed
+  * notifications: log directly when upgrading metadata version
+  * notifications: log directly when uninstalling toolchains
+  * notifications: log directly when toolchain is up to date
+  * notifications: log directly when toolchain has been installed
+  * notifications: log directly when installing toolchains
+  * notifications: log the toolchain directory directly
+  * notifications: log directly when using existing toolchains
+  * notifications: log directly when looking for toolchains
++++ 250 more lines (skipped)
++++ between /work/SRC/openSUSE:Factory/rustup/rustup.changes
++++ and /work/SRC/openSUSE:Factory/.rustup.new.1258/rustup.changes

Old:
----
  rustup-1.28.2~0.tar.zst

New:
----
  rustup-1.29.0~0.tar.zst

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rustup.spec ++++++
--- /var/tmp/diff_new_pack.VDiZWm/_old  2026-08-14 22:05:57.516813204 +0200
+++ /var/tmp/diff_new_pack.VDiZWm/_new  2026-08-14 22:05:57.520813347 +0200
@@ -29,7 +29,7 @@
 Obsoletes:      %{1}1.51%{?2:-%{2}} < %{rust_version}
 
 Name:           rustup
-Version:        1.28.2~0
+Version:        1.29.0~0
 Release:        0
 Summary:        A tool for managing user Rust toolchains
 License:        (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR BSL-1.0) AND 
(Apache-2.0 OR ISC OR MIT) AND (Apache-2.0 OR MIT) AND (Apache-2.0 OR MIT OR 
Zlib) AND (Apache-2.0 OR MIT OR Zlib) AND (MIT OR Unlicense) AND (Apache-2.0 OR 
Zlib OR MIT) AND Apache-2.0 AND BSD-3-Clause AND CC0-1.0 AND ISC AND MIT

++++++ _service ++++++
--- /var/tmp/diff_new_pack.VDiZWm/_old  2026-08-14 22:05:57.575815310 +0200
+++ /var/tmp/diff_new_pack.VDiZWm/_new  2026-08-14 22:05:57.578815417 +0200
@@ -3,7 +3,7 @@
     <param name="url">https://github.com/rust-lang/rustup.git</param>
     <param name="versionformat">@PARENT_TAG@~@TAG_OFFSET@</param>
     <param name="scm">git</param>
-    <param name="revision">1.28.2</param>
+    <param name="revision">1.29.0</param>
     <param name="match-tag">*</param>
     <param name="versionrewrite-pattern">(\d+\.\d+\.\d+)</param>
     <param name="versionrewrite-replacement">\1</param>

++++++ _servicedata ++++++
--- /var/tmp/diff_new_pack.VDiZWm/_old  2026-08-14 22:05:57.619816881 +0200
+++ /var/tmp/diff_new_pack.VDiZWm/_new  2026-08-14 22:05:57.625817095 +0200
@@ -1,6 +1,6 @@
 <servicedata>
 <service name="tar_scm">
                 <param 
name="url">https://github.com/rust-lang/rustup.git</param>
-              <param 
name="changesrevision">e4f3ad6f893e56ca10f0a329c401a5eafab69607</param></service></servicedata>
+              <param 
name="changesrevision">28d1352dbcb436d3111c3594b9e1588e94950464</param></service></servicedata>
 (No newline at EOF)
 

++++++ rustup-1.28.2~0.tar.zst -> rustup-1.29.0~0.tar.zst ++++++
++++ 46483 lines of diff (skipped)

++++++ rustup.obsinfo ++++++
--- /var/tmp/diff_new_pack.VDiZWm/_old  2026-08-14 22:05:58.005830659 +0200
+++ /var/tmp/diff_new_pack.VDiZWm/_new  2026-08-14 22:05:58.012830909 +0200
@@ -1,5 +1,5 @@
 name: rustup
-version: 1.28.2~0
-mtime: 1745855794
-commit: e4f3ad6f893e56ca10f0a329c401a5eafab69607
+version: 1.29.0~0
+mtime: 1772692288
+commit: 28d1352dbcb436d3111c3594b9e1588e94950464
 

++++++ vendor.tar.zst ++++++
/work/SRC/openSUSE:Factory/rustup/vendor.tar.zst 
/work/SRC/openSUSE:Factory/.rustup.new.1258/vendor.tar.zst differ: char 8, line 
1

Reply via email to